1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed FFMPEG Issues

Discussion in 'Media Gallery Resolved Bugs' started by Liam W, Aug 21, 2015.

  1. Liam W

    Liam W Well-Known Member


    I've installed ffmpeg using centminmod system, and setup the option, however it keeps on telling me it can't be run...

    Running it manually, I get output:

    [root@torture Helper]# /usr/bin/ffmpeg -encoders
    FFmpeg version 0.6.5, Copyright (c) 2000-2010 the FFmpeg developers
      built on Jan 29 2012 17:52:15 with gcc 4.4.5 20110214 (Red Hat 4.4.5-6)
      configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --mandir=/usr/share/man --incdir=/usr/include --disable-avisynth --extra-cflags='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fPIC' --enable-avfilter --enable-avfilter-lavf --enable-libdc1394 --enable-libdirac --enable-libfaac --enable-libfaad --enable-libfaadbin --enable-libgsm --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libx264 --enable-gpl --enable-nonfree --enable-postproc --enable-pthreads --enable-shared --enable-swscale --enable-vdpau --enable-version3 --enable-x11grab
      libavutil     50.15. 1 / 50.15. 1
      libavcodec    52.72. 2 / 52.72. 2
      libavformat   52.64. 2 / 52.64. 2
      libavdevice   52. 2. 0 / 52. 2. 0
      libavfilter    1.19. 0 /  1.19. 0
      libswscale     0.11. 0 /  0.11. 0
      libpostproc   51. 2. 0 / 51. 2. 0
    /usr/bin/ffmpeg: missing argument for option 'encoders'
    However, the output includes an error, and the command returns a status code of 1, which of course makes XFMG complain.

    Any ideas?

  2. Martok

    Martok Well-Known Member

    That looks like a very old version of FFMPEG. I got mine updated recently and it's version is 4.1.2.
  3. Chris D

    Chris D XenForo Developer Staff Member

    XFMG requires FFMPEG version 1.1.0 and above. You need to update it.

    Annoyingly, the version check doesn't seem to be actually working properly - it needs a return code of 0 to get that far, and obviously it isn't in this case, so I do need to move this to bugs but ultimately it doesn't change the fact you need to update ;)
    Liam W likes this.
  4. Chris D

    Chris D XenForo Developer Staff Member

    By the way; the simplest way to get this working is to use an FFMPEG static build:
    FFmpeg Static Builds

    Just replace the ffmpeg binary on your server with the one in the download package on that page. You literally only need to worry about the ffmpeg file - we don't use any of the others in the bundle.
    eva2000 and Liam W like this.
  5. RoldanLT

    RoldanLT Well-Known Member

    Yes, I'm centminmod user also.
    But I do not install anything, I just downloaded the static build and everything works as expected.
    eva2000 likes this.
  6. Chris D

    Chris D XenForo Developer Staff Member

    I have made some changes here for the next release.

    In the event that the -encoders argument doesn't exist in FFmpeg because it's an old version, we still inspect the shell output because that will actually contain the FFmpeg version details, and therefore we can show you a more detailed error.

    I also cleared up a bit of potential ambiguity in the code whereby if we couldn't find a version, we assumed it was version 0 therefore would give an error about the version not being supported which may not be correct. Similar change was made with regards to looking for the supported encoders.

    Finally, in case you're still having difficulty setting this up, we published a guide in the Resource Manager today which may help:

    Compiling FFmpeg From Source

    Lazek and eva2000 like this.

Share This Page