No matter what folder ffmpeg is in, I keep getting open_basedir error!!


Well-known member
I don't need to convert any videos, I just want thumbnails and posters for mp4 uploads. I'm using PHP 8.2.13, Ubuntu 20.04, Apache, and Plesk Web Pro 18. I've tried putting the ffmpeg binary (I'm to understand that's all I need for thumbnails) in many different folders. Some within the allowed paths, some without, and it says "Cannot execute FFmpeg at the specified path", or "FFmpeg not found on path", or the below server error. I've tried "/var/www/vhosts/", /var/www/vhosts/", "/var/www/vhosts/", etc. in XFMG options for ffmpeg path. But it won't work. I even disabled open_basedir in my PHP.ini, and it still didn't work! I also changed the filename on the server to "FFmpeg". Still nothing. See below please:

The current entry for open_basedir in my PHP.ini:

The open_basedir value in my PHP settings on Plesk:

And finally:
ErrorException: [E_WARNING] file_exists(): open_basedir restriction in effect. File(/var/www/vhosts/ is not within the allowed path(s): (/var/www/vhosts/ in src/addons/XFMG/Validator/Ffmpeg.php at line 20
file_exists() in src/addons/XFMG/Validator/Ffmpeg.php at line 20
XFMG\Validator\Ffmpeg->isValid() in src/addons/XFMG/Option/Ffmpeg.php at line 25
XFMG\Option\Ffmpeg::verifyOption() in src/XF/Entity/Option.php at line 208
XF\Entity\Option->verifyOptionValue() in src/XF/Mvc/Entity/Entity.php at line 798
XF\Mvc\Entity\Entity->_verifyValueCustom() in src/XF/Mvc/Entity/Entity.php at line 643
XF\Mvc\Entity\Entity->set() in src/XF/Mvc/Entity/Entity.php at line 577
XF\Mvc\Entity\Entity->__set() in src/XF/Repository/Option.php at line 113
XF\Repository\Option->updateOptions() in src/XF/Admin/Controller/Option.php at line 86
XF\Admin\Controller\Option->actionUpdate() in src/XF/Mvc/Dispatcher.php at line 352
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 258
XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 115
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 57
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2483
XF\App->run() in src/XF.php at line 524
XF::runApp() in admin.php at line 13

I've been messing with this the better part of the day. I remember it working before. I just migrated to a better server using Plesk to Plesk transfer, and it duplicated everything and the itself works perfectly.

Help please! :D
Top Bottom