1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Fatal error: Out of memory

Discussion in 'Troubleshooting and Problems' started by IcEWoLF, May 15, 2013.

  1. IcEWoLF

    IcEWoLF Well-Known Member

    Fatal error: Out of memory (allocated 6029312) (tried to allocate 84 bytes) in /home/xxxxxxxx/xxxxxxxxxx/library/Zend/Db/Statement/Mysqli.php on line 304

    I've been getting this problem time to time.

    My host set my php limit to 512mb

    Not sure what else to do here.
    There are no threads awaiting for moderation.
     
  2. The Forum Heroes

    The Forum Heroes Well-Known Member

    Have him set it to -1
     
    IcEWoLF likes this.
  3. IcEWoLF

    IcEWoLF Well-Known Member

    Thanks, I'll give that a try and see if it works.
    I think the only other thing I can do other than that is to ask for a ram upgrade for my VPS?
     
  4. IcEWoLF

    IcEWoLF Well-Known Member

    Well here is the reply my host gave me:

     
  5. The Forum Heroes

    The Forum Heroes Well-Known Member

    It should be fine. We use -1 and then control each account at a package level via Cloud Linux.

    How much RAM does your VPS have?
     
  6. IcEWoLF

    IcEWoLF Well-Known Member

    2gb + 1gb swap.
     
  7. The Forum Heroes

    The Forum Heroes Well-Known Member

    Try 1024 if you don't feel comfortable using -1
     
  8. Mike

    Mike XenForo Developer Staff Member

    This isn't a memory_limit thing. It's an out of memory error - as in, PHP couldn't allocate memory. In this case, after about 6MB. I'm not going to say you need more memory, but you may need to tune the memory usage of various services.
     
    IcEWoLF likes this.
  9. CyclingTribe

    CyclingTribe Well-Known Member

    Where do you see this error / what are you (your members) doing when it happens?

    Does it happen only in the ACP or during a particular task / request?
     
  10. WSWD

    WSWD Well-Known Member

    If the memory limit was previously 512mb, increasing it to 1GB or even -1 shouldn't make a bit of difference. It's happening after 6mb.

    Why don't you post the contents of your php.ini file and we can go from there. Something doesn't sound right.
     
  11. IcEWoLF

    IcEWoLF Well-Known Member

    Here is the phpinfo: http://www.47r-squad.com/phpinfo.php
     
  12. WSWD

    WSWD Well-Known Member

    Thanks,

    Try going to your httpd.conf file, and looking for RLimitMEM. Remove the line (or comment it out) if it exists, restart Apache and see if that does the trick. Your php.ini generally looks normal.
     
    Jake Bunce likes this.
  13. IcEWoLF

    IcEWoLF Well-Known Member

  14. DarkGizmo

    DarkGizmo Active Member

    Disable that mod then and see if that fixes your problems, that's kind of the obvious way of troubleshooting it and knowing for sure if that's the mod's fault or not.
     
  15. IcEWoLF

    IcEWoLF Well-Known Member

    Disabled the mod and did not have an issue all day long.
    Re-enabled the mod and today I've been having issues, so something with this mod is causing the memory issue.
     
  16. IcEWoLF

    IcEWoLF Well-Known Member

    Update, I disabled the mod and after a day, this issue is still happening, we disabled all the mods but no fix yet, we even were moved to a new node and the issue still persists.
    I am running out of options.
     
  17. WSWD

    WSWD Well-Known Member

    Did you try what I mentioned?

     
    IcEWoLF likes this.
  18. IcEWoLF

    IcEWoLF Well-Known Member


    Sorry missed that, will open a ticket tonight about it and see if they can do this.
    Here is also an attachment of mysqlmymonlite.
     

    Attached Files:

  19. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    https://drupal.org/node/463234#comment-1794502
    > https://drupal.org/node/371789#comment-1334640

    I think WSWD may be correct. This error is not from PHP's memory_limit, so it may be from Apache:

    Your host needs to check this for you. You cannot access httpd.conf without root access.
     
    IcEWoLF likes this.
  20. IcEWoLF

    IcEWoLF Well-Known Member

    Thanks guys, I submitted the ticket , unfortunately the host is being terrible as of late since it's takes them nearly a day to reply to a ticket...time for me to consider looking for a new vps server provider soon. :mad:
     

Share This Page