• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Facebook Integration - Sharing privacy problems.

CoryWM

New member
#1
I can't seem to search for the answer here or on google. Basically when I share a post from the forum to my facebook or a group. The privacy defaults to "me only" instead of public. I'm assuming this has to do with how the facebook integration app is created. I'm looking for documentation on how I can modify that so that it shares default being public.

Thanks.
 

Mike

XenForo developer
Staff member
#2
As far as I'm aware, there's nothing on the website site that would be involved with this. I believe it would be down to your default share settings in Facebook.
 

CoryWM

New member
#4
Still having problems. I have changed it to public on that screen for apps.

If I manually copy and paste the link to the group it works fine. If I share it via xenforo and the "app" that is created it doesn't share correctly. Thus I need a tutorial somewhere on how to setup the app correctly as following the normal directions from the xenforo FAQ isn't getting me there.
 

Chris D

XenForo developer
Staff member
#5
There are no app based settings for this. Apps should not be able to control the privacy on behalf of a user. Sharing should always configured based on the user's own preferences.

With that in mind, the only related settings I can think of are the ones posted by Mouth above.

I can reproduce the issue you are describing if the "App visibility" setting for an app is set to "Only Me". Anything I then click "Recommend/Like" on will only be visible to me. However if I set this to public, anything I then click "Recommend/Like" on is public.