1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Facebook integration - no email returned

Discussion in 'Resolved Bug Reports' started by Sim, Jul 11, 2015.

  1. Sim

    Sim Well-Known Member

    I'm hoping someone can help me troubleshoot Facebook integration for my site - when I test the integration it is not returning an email address.


    I've done a lot of reading about this and most people point to not having a verified email address specified as your primary contact in your Facebook profile, but I've checked that and removed/re-added my email addresses several times to make sure it's not that.


    I also asked a few of my members to test the integration by trying to link their forum accounts with their Facebook profiles, but in every case they got the error about an email address not being returned.


    Here are my Facebook App setup details:



    ... now interestingly, I have had no difficulty disassociating my xenforo.com forum account with my facebook profile and then re-adding it again. So I'm pretty sure that there is nothing wrong with my Facebook account.

    I read somewhere about using the Graph API Explorer to test whether the email address is returned correctly:


    ... which it is ...


    ... I'm at a loss as to what else to try to troubleshoot this issue.

    Any suggestions?

    I also tried setting up Facebook integration with one of my other XenForo forums and had the same problem - so I don't think it's specific to my XenForo installation.
    Last edited: Jul 11, 2015
  2. Dakis

    Dakis Well-Known Member

    I have the same issue
  3. MS1

    MS1 Member

    I have exactly the same problem described by @Sim !
  4. Sim

    Sim Well-Known Member

    @Dakis @MS1 ... have either of you associated your xenforo.com accounts with your Facebook accounts?

    Curious to know if it worked for you (it did for me).

    @MS1 ... can I guess based on your avatar that you are also in Australia like Dakis and myself?

    Perhaps this is a localised Facebook issue - which is why it works on xenforo.com, but not for us?
  5. Dakis

    Dakis Well-Known Member

    No I haven't. Good catch that all 3 of us are in Australia, perhaps it is an issue here, who knows?

    Just wanted to mention I'm testing this on the latest 1.5 beta.
  6. Chris D

    Chris D XenForo Developer Staff Member

    @MS1 doesn't appear to be in Australia, by the way :)
  7. Brogan

    Brogan XenForo Moderator Staff Member

    It works fine for me on multiple installations/domain/FB accounts.

    You could try registering a new FB account and app to see if that works (not sure on FB's policy with regards to that).
  8. MS1

    MS1 Member

    Hi guys,

    I'm embarrassed...I'm german :D
    Sorry, for the misleading avatar. At that time I wanted to test the avatars function quickly and took the first picture that came along. Nevertheless some germans also like koala bears ;)

    Honestly, I don't know much about the coding of the login system with social media.
    So, I can't analyse the error on the API level to find the solution.

    I only assume that there must be an error/ false setting in our (@Sim , @Dakis ) Xenforo-Facebook connection!? If there would be a problem with your personal facebook account you couldn't login on other sites.
    Or is this argument invalid?
  9. Sim

    Sim Well-Known Member

    Unfortunately I'm pretty sure that is not allowed ... although I guess there's nothing stopping you from doing it for testing purposes.
  10. Sim

    Sim Well-Known Member

    It's okay - I'm from South Australia ... and descended from German ancestors who emigrated to Australia back in the 1850s - lots of German influence where I come from :D
    MS1 likes this.
  11. Sim

    Sim Well-Known Member

    Okay, I created a brand new Facebook account, registered for the Developers program, created my app and had exactly the same problem :(

    I'd really appreciate any suggestions on how we can go about debugging or troubleshooting this problem.

    @Brogan (or any other staff member), is there any chance we could experiment with you (temporarily) creating a Facebook App for me to test with to try and isolate where the issue might lie?
    MS1 likes this.
  12. Brogan

    Brogan XenForo Moderator Staff Member

    @Sim, if you can send me an ACP log in I can check with a test FB account.
  13. owtlawatv

    owtlawatv Member

    Im having the same exact problem, has there been a fix for this yet?
  14. owtlawatv

    owtlawatv Member

    I created a test FB account and still same issue... I wonder if its FB or XF
  15. Chris D

    Chris D XenForo Developer Staff Member

    At this stage there's no reason to believe it's XF because it appears to be working for most people, though they make so many changes to the API it's hard to say, and people can opt in and out of certain API changes.

    I have been meaning to come back to this and check a few things relating to any new breaking changes they are implementing. I'll let you know if I can make sense of it.
  16. Mike

    Mike XenForo Developer Staff Member

    Has everyone with this problem just recently created their Facebook app? (Specifically, within the last week?)
  17. Mike

    Mike XenForo Developer Staff Member

    This appears to be related to the new 2.4 API (which was activated on July 8th) and the way that API created (or first used) after it was enabled will not be able to use older versions. Our next release will change to use 2.4 and the include the necessary code changes to support it.
    Liam W, Dakis, Sim and 1 other person like this.
  18. Sim

    Sim Well-Known Member

    Yes, I've been using newly created apps. This would certainly explain the problem everyone has been having - thanks Mike.

    I have some old apps for other sites I'm not currently using - I might try and see if I can repurpose one of those and make it work. Will report back.

    @Mike when you say "our next release" are you referring to 1.5?
  19. Sim

    Sim Well-Known Member

    @Mike I can confirm that a re-purposed Facebook App with access to API versions back to 2.0 does work as expected.

  20. Mike

    Mike XenForo Developer Staff Member

    It's been fixed for the next 1.4 release as well as 1.5. It'll be in a 1.5 beta release earlier, but we don't recommend running those in production, so I'm not sure if that counts.

Share This Page