• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Facebook Integration forces option for Login With Facebook too?

XenBurger

Active member
#1
"Login with Facebook" has now appeared on my forum login screen and I do not want it there.

I set up "Facebook integration" for other reasons. Namely because I wanted Facebook "Sharing" to work properly. The snippet text, title, and main image were not being pulled in correctly until I set that up.

However I do not want users logging in with their facebook accounts. Was this placed on my login popup when I added Facebook integration?

I don't see a checkbox there saying "Allow FB logins" - so it must be somewhere else. Can you tell me where?
 
Last edited:

Mike

XenForo developer
Staff member
#2
What appears when sharing a URL on Facebook would not be related to having a Facebook app. The app you created is specifically to enable Facebook logins and account associations, so there isn't a separate switch. If you don't want to allow that, you'll need to remove the app key and secret from the options.

If you're having issues with sharing, then we'd need more details about that to give specific suggestions.
 

XenBurger

Active member
#3
What appears when sharing a URL on Facebook would not be related to having a Facebook app. The app you created is specifically to enable Facebook logins and account associations, so there isn't a separate switch. If you don't want to allow that, you'll need to remove the app key and secret from the options.

If you're having issues with sharing, then we'd need more details about that to give specific suggestions.

It was this:
https://xenforo.com/community/threa...image-og-description-etc.131463/#post-1161561

So removing the "app key" wont affect the issue mentioned in the link above?
 
Last edited:

Mike

XenForo developer
Staff member
#4
The default OG tags aren't wrapped in any sort of conditional. You can get specific details of what Facebook is seeing via their debugger: https://developers.facebook.com/tools/debug/sharing/

Significantly, on your site, I'm seeing an error like this (you may need to refetch to see it):
Your page has meta tags in the body instead of the head. This may be because your HTML was malformed and they fell lower in the parse tree.
Please fix this in order for the tags to be usable.
That will be related to your style or a modification.
 

XenBurger

Active member
#6
@Mike - still a little confused - even if my meta tags were in the wrong location, you would still want "OG" tags on the page, and I thought adding facebook ID / app is the only way to do that if you want to communicate OG info to Facebook (boy this is confusing). Not true?
 

Mike

XenForo developer
Staff member
#7
No, the OG title and so on are always output (they are not Facebook-specific any more).