1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Facebook Integration error

Discussion in 'Troubleshooting and Problems' started by Ruone Delacroix, Sep 13, 2011.

  1. I've been working on trying to get Facebook integrated with my site, and after following the guide in the help section, I got it all set up. After Apache was updated on the server to get the SSL protocol installed, I get this message when I test the integration or try to log in using Facebook:

    Code:
    Server Error
    
    curl_exec() has been disabled for security reasons
    XenForo_Application::handlePhpError()
    curl_exec() in Zend/Http/Client/Adapter/Curl.php at line 411
    Zend_Http_Client_Adapter_Curl->write() in Zend/Http/Client.php at line 987
    Zend_Http_Client->request() in XenForo/Helper/Facebook.php at line 37
    XenForo_Helper_Facebook::getAccessToken() in XenForo/Helper/Facebook.php at line 74
    XenForo_Helper_Facebook::getAccessTokenFromCode() in XenForo/ControllerAdmin/Tools.php at line 107
    XenForo_ControllerAdmin_Tools->actionTestFacebook() in XenForo/FrontController.php at line 310
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    XenForo_FrontController->run() in /home/nexusof/public_html/admin.php at line 13
    I'm not really sure what the problem is, and I'm not server-savvy. I tried looking it up here, but I can't find anything.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It looks like you need to install cURL on your server.

     
  3. I've seen that response and I was thinking that my issue would be a bit different. Thanks for the response once again, Brogan.
     

Share This Page