XF 2.2 Error submitting sitemap to Bing

JoyFreak

Well-known member
Just had this error logged in the Admin CP. It only occurred once, earlier today. Any concerns or can be ignored?
Code:
Server error log
GuzzleHttp\Exception\ClientException: Error submitting sitemap to https://www.google.com/webmasters/tools/ping?sitemap=https%3A%2F%2Fwww.joyfreak.com%2Fsitemap.php: Client error: `GET https://www.google.com/webmasters/tools/ping?sitemap=https%3A%2F%2Fwww.joyfreak.com%2Fsitemap.php` resulted in a `429 Too Many Requests` response: <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> <html> <head><meta http-equiv="content-type" content="te (truncated...) src/vendor/guzzlehttp/guzzle/src/Exception/RequestException.php:113
Generated by: Unknown account Dec 13, 2021 at 8:22 AM
Stack trace
#0 src/vendor/guzzlehttp/guzzle/src/Middleware.php(66): GuzzleHttp\Exception\RequestException::create(Object(GuzzleHttp\Psr7\Request), Object(GuzzleHttp\Psr7\Response))
#1 src/vendor/guzzlehttp/promises/src/Promise.php(204): GuzzleHttp\Middleware::GuzzleHttp\{closure}(Object(GuzzleHttp\Psr7\Response))
#2 src/vendor/guzzlehttp/promises/src/Promise.php(153): GuzzleHttp\Promise\Promise::callHandler(1, Object(GuzzleHttp\Psr7\Response), NULL)
#3 src/vendor/guzzlehttp/promises/src/TaskQueue.php(48): GuzzleHttp\Promise\Promise::GuzzleHttp\Promise\{closure}()
#4 src/vendor/guzzlehttp/promises/src/Promise.php(248): GuzzleHttp\Promise\TaskQueue->run(true)
#5 src/vendor/guzzlehttp/promises/src/Promise.php(224): GuzzleHttp\Promise\Promise->invokeWaitFn()
#6 src/vendor/guzzlehttp/promises/src/Promise.php(269): GuzzleHttp\Promise\Promise->waitIfPending()
#7 src/vendor/guzzlehttp/promises/src/Promise.php(226): GuzzleHttp\Promise\Promise->invokeWaitList()
#8 src/vendor/guzzlehttp/promises/src/Promise.php(62): GuzzleHttp\Promise\Promise->waitIfPending()
#9 src/vendor/guzzlehttp/guzzle/src/Client.php(131): GuzzleHttp\Promise\Promise->wait()
#10 src/vendor/guzzlehttp/guzzle/src/Client.php(89): GuzzleHttp\Client->request('get', 'https://www.goo...', Array)
#11 src/XF/Sitemap/Builder.php(508): GuzzleHttp\Client->__call('get', Array)
#12 src/XF/Sitemap/Builder.php(432): XF\Sitemap\Builder->sendPing()
#13 src/XF/Sitemap/Builder.php(73): XF\Sitemap\Builder->completeBuild()
#14 src/XF/Job/Sitemap.php(27): XF\Sitemap\Builder->build(2.79395)
#15 src/XF/Job/Manager.php(260): XF\Job\Sitemap->run(8)
#16 src/XF/Job/Manager.php(202): XF\Job\Manager->runJobInternal(Array, 8)
#17 src/XF/Job/Manager.php(118): XF\Job\Manager->runJobEntry(Array, 8)
#18 src/XF/Admin/Controller/Tools.php(122): XF\Job\Manager->runByIds(Array, 8)
#19 src/XF/Mvc/Dispatcher.php(352): XF\Admin\Controller\Tools->actionRunJob(Object(XF\Mvc\ParameterBag))
#20 src/XF/Mvc/Dispatcher.php(259): XF\Mvc\Dispatcher->dispatchClass('XF:Tools', 'RunJob', Object(XF\Mvc\RouteMatch), Object(ThemeHouse\UserCriteria\XF\Admin\Controller\Tools), NULL)
#21 src/XF/Mvc/Dispatcher.php(115): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(ThemeHouse\UserCriteria\XF\Admin\Controller\Tools), NULL)
#22 src/XF/Mvc/Dispatcher.php(57): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#23 src/XF/App.php(2351): XF\Mvc\Dispatcher->run()
#24 src/XF.php(517): XF\App->run()
#25 admin.php(13): XF::runApp('XF\\Admin\\App')
#26 {main}
Request state
array(4) {
  ["url"] => string(24) "/admin.php?tools/run-job"
  ["referrer"] => string(120) "https://www.joyfreak.com/admin.php?tools/run-job&only_id=104412&_xfRedirect=%2Fadmin.php%3Ftools%2Frebuild%26success%3D1"
  ["_GET"] => array(1) {
    ["tools/run-job"] => string(0) ""
  }
  ["_POST"] => array(3) {
    ["_xfRedirect"] => string(58) "https://www.joyfreak.com/admin.php?tools/rebuild&success=1"
    ["_xfToken"] => string(8) "********"
    ["only_ids"] => string(6) "104412"
  }
}
 
Solution
So to be clear this is an issue solely on the Bing end and can be safely ignored.

I don’t know how you go about reporting issues to Bing but it’s likely that enough people need to make them aware and hopefully that will prompt them to turn it off and on again.

Hopefully this isn't a planned closure of the sitemap ping endpoint. If it is, I can't see it documented anywhere...

It seems Bing are going all-in on their IndexNow protocol but I can't see them doing away with sitemaps just yet.

Does anyone actually have a Bing Webmaster Tools account? If so, please open a ticket or send them an email regarding this or please look for any further clues about what might be going on.

Cheers :)

JoyFreak

Well-known member
I emailed them myself and got the following:
Hope you are doing good. After detailed review, I see that the sitemap got successfully submitted to Bing Webmaster console. Here is the screenshot for reference.

The screenshot shows that the sitemap was last crawled on the 25/12/2021 via the Bing Webmaster console. It seems to crawl automatically? Maybe a ping isn't needed anymore?

I think since this has affected several XenForo customers, it's up to the developers to look into it and update the software accordingly. Until then, there's not much we can do.
 

gerryvz

Well-known member
I changed the submission URL per the post above, and it seems to be now submitting OK.

A workaround, I guess, until the Bing submission URL changes yet again.....
 

gerryvz

Well-known member
Happened for the first time this morning on my second forum.

I have had success by changing the sitemap submission URL for Bing to the one mentioned above, and haven't had any further errors on my first forum since changing it a couple of days ago.
 

ideasmania

Member
I also have this error, and I submitted the Xenforo sitemap some weeks ago on the Bing webmaster account.
I will ignore the issue temporarily, if the warning continues, probably will take out the sitemap from the Bing account.
 

Masetrix

Well-known member
"RTFT"

The solution to this problem has already been given in this posting.

Error "410 Gone" means that this type of service is no longer valid!
 

Ozzy47

Well-known member
Today same error

I am now getting this multiple times every day.

So do this till Bing fixes the issue.:
The ping URLs are customisable in your sitemap options so as a workaround you can replace the Bing one with:

Code:
https://bing.com/webmaster/ping.aspx?sitemap={url}
...but if the current one starts working I'd recommend putting that one back.
 

Silmarillion

Active member
Same here...since Dec 24...

Code:
     GuzzleHttp\Exception\ClientException: Error submitting sitemap to https://www.bing.com/ping?sitemap=https%3A%2F%2Fwww.fanlager.de%2Fsitemap.php: Client error: `GET https://www.bing.com/ping?sitemap=https%3A%2F%2Fwww.fanlager.de%2Fsitemap.php` resulted in a `410 Gone` response src/vendor/guzzlehttp/guzzle/src/Exception/RequestException.php:113
    
     Stack-Trace

#0 src/vendor/guzzlehttp/guzzle/src/Middleware.php(66): GuzzleHttp\Exception\RequestException::create(Object(GuzzleHttp\Psr7\Request), Object(GuzzleHttp\Psr7\Response))
#1 src/vendor/guzzlehttp/promises/src/Promise.php(204): GuzzleHttp\Middleware::GuzzleHttp\{closure}(Object(GuzzleHttp\Psr7\Response))
#2 src/vendor/guzzlehttp/promises/src/Promise.php(153): GuzzleHttp\Promise\Promise::callHandler(1, Object(GuzzleHttp\Psr7\Response), NULL)
#3 src/vendor/guzzlehttp/promises/src/TaskQueue.php(48): GuzzleHttp\Promise\Promise::GuzzleHttp\Promise\{closure}()
#4 src/vendor/guzzlehttp/promises/src/Promise.php(248): GuzzleHttp\Promise\TaskQueue->run(true)
#5 src/vendor/guzzlehttp/promises/src/Promise.php(224): GuzzleHttp\Promise\Promise->invokeWaitFn()
#6 src/vendor/guzzlehttp/promises/src/Promise.php(269): GuzzleHttp\Promise\Promise->waitIfPending()
#7 src/vendor/guzzlehttp/promises/src/Promise.php(226): GuzzleHttp\Promise\Promise->invokeWaitList()
#8 src/vendor/guzzlehttp/promises/src/Promise.php(62): GuzzleHttp\Promise\Promise->waitIfPending()
#9 src/vendor/guzzlehttp/guzzle/src/Client.php(131): GuzzleHttp\Promise\Promise->wait()
#10 src/vendor/guzzlehttp/guzzle/src/Client.php(89): GuzzleHttp\Client->request('get', 'https://www.bin...', Array)
#11 src/XF/Sitemap/Builder.php(506): GuzzleHttp\Client->__call('get', Array)
#12 src/XF/Sitemap/Builder.php(430): XF\Sitemap\Builder->sendPing()
#13 src/XF/Sitemap/Builder.php(71): XF\Sitemap\Builder->completeBuild()
#14 src/XF/Job/Sitemap.php(25): XF\Sitemap\Builder->build(4.3475)
#15 src/XF/Job/Manager.php(258): XF\Job\Sitemap->run(8)
#16 src/XF/Job/Manager.php(200): XF\Job\Manager->runJobInternal(Array, 8)
#17 src/XF/Job/Manager.php(84): XF\Job\Manager->runJobEntry(Array, 8)
#18 job.php(43): XF\Job\Manager->runQueue(false, 8)
#19 {main}
 

swiftyste

Active member
Same here...since Dec 24...

Code:
     GuzzleHttp\Exception\ClientException: Error submitting sitemap to https://www.bing.com/ping?sitemap=https%3A%2F%2Fwww.fanlager.de%2Fsitemap.php: Client error: `GET https://www.bing.com/ping?sitemap=https%3A%2F%2Fwww.fanlager.de%2Fsitemap.php` resulted in a `410 Gone` response src/vendor/guzzlehttp/guzzle/src/Exception/RequestException.php:113
  
     Stack-Trace

#0 src/vendor/guzzlehttp/guzzle/src/Middleware.php(66): GuzzleHttp\Exception\RequestException::create(Object(GuzzleHttp\Psr7\Request), Object(GuzzleHttp\Psr7\Response))
#1 src/vendor/guzzlehttp/promises/src/Promise.php(204): GuzzleHttp\Middleware::GuzzleHttp\{closure}(Object(GuzzleHttp\Psr7\Response))
#2 src/vendor/guzzlehttp/promises/src/Promise.php(153): GuzzleHttp\Promise\Promise::callHandler(1, Object(GuzzleHttp\Psr7\Response), NULL)
#3 src/vendor/guzzlehttp/promises/src/TaskQueue.php(48): GuzzleHttp\Promise\Promise::GuzzleHttp\Promise\{closure}()
#4 src/vendor/guzzlehttp/promises/src/Promise.php(248): GuzzleHttp\Promise\TaskQueue->run(true)
#5 src/vendor/guzzlehttp/promises/src/Promise.php(224): GuzzleHttp\Promise\Promise->invokeWaitFn()
#6 src/vendor/guzzlehttp/promises/src/Promise.php(269): GuzzleHttp\Promise\Promise->waitIfPending()
#7 src/vendor/guzzlehttp/promises/src/Promise.php(226): GuzzleHttp\Promise\Promise->invokeWaitList()
#8 src/vendor/guzzlehttp/promises/src/Promise.php(62): GuzzleHttp\Promise\Promise->waitIfPending()
#9 src/vendor/guzzlehttp/guzzle/src/Client.php(131): GuzzleHttp\Promise\Promise->wait()
#10 src/vendor/guzzlehttp/guzzle/src/Client.php(89): GuzzleHttp\Client->request('get', 'https://www.bin...', Array)
#11 src/XF/Sitemap/Builder.php(506): GuzzleHttp\Client->__call('get', Array)
#12 src/XF/Sitemap/Builder.php(430): XF\Sitemap\Builder->sendPing()
#13 src/XF/Sitemap/Builder.php(71): XF\Sitemap\Builder->completeBuild()
#14 src/XF/Job/Sitemap.php(25): XF\Sitemap\Builder->build(4.3475)
#15 src/XF/Job/Manager.php(258): XF\Job\Sitemap->run(8)
#16 src/XF/Job/Manager.php(200): XF\Job\Manager->runJobInternal(Array, 8)
#17 src/XF/Job/Manager.php(84): XF\Job\Manager->runJobEntry(Array, 8)
#18 job.php(43): XF\Job\Manager->runQueue(false, 8)
#19 {main}
Best bet is do the following like above until bing or i stop breaking it :D

I noticed this too but, technically, that's the old URL. Presumably it may be shutdown at some point.

The ping URLs are customisable in your sitemap options so as a workaround you can replace the Bing one with:

Code:
https://bing.com/webmaster/ping.aspx?sitemap={url}

...but if the current one starts working I'd recommend putting that one back.
 
Top