XF 2.2 Error submitting sitemap to Bing

JoyFreak

Well-known member
Just had this error logged in the Admin CP. It only occurred once, earlier today. Any concerns or can be ignored?
Code:
Server error log
GuzzleHttp\Exception\ClientException: Error submitting sitemap to https://www.google.com/webmasters/tools/ping?sitemap=https%3A%2F%2Fwww.joyfreak.com%2Fsitemap.php: Client error: `GET https://www.google.com/webmasters/tools/ping?sitemap=https%3A%2F%2Fwww.joyfreak.com%2Fsitemap.php` resulted in a `429 Too Many Requests` response: <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> <html> <head><meta http-equiv="content-type" content="te (truncated...) src/vendor/guzzlehttp/guzzle/src/Exception/RequestException.php:113
Generated by: Unknown account Dec 13, 2021 at 8:22 AM
Stack trace
#0 src/vendor/guzzlehttp/guzzle/src/Middleware.php(66): GuzzleHttp\Exception\RequestException::create(Object(GuzzleHttp\Psr7\Request), Object(GuzzleHttp\Psr7\Response))
#1 src/vendor/guzzlehttp/promises/src/Promise.php(204): GuzzleHttp\Middleware::GuzzleHttp\{closure}(Object(GuzzleHttp\Psr7\Response))
#2 src/vendor/guzzlehttp/promises/src/Promise.php(153): GuzzleHttp\Promise\Promise::callHandler(1, Object(GuzzleHttp\Psr7\Response), NULL)
#3 src/vendor/guzzlehttp/promises/src/TaskQueue.php(48): GuzzleHttp\Promise\Promise::GuzzleHttp\Promise\{closure}()
#4 src/vendor/guzzlehttp/promises/src/Promise.php(248): GuzzleHttp\Promise\TaskQueue->run(true)
#5 src/vendor/guzzlehttp/promises/src/Promise.php(224): GuzzleHttp\Promise\Promise->invokeWaitFn()
#6 src/vendor/guzzlehttp/promises/src/Promise.php(269): GuzzleHttp\Promise\Promise->waitIfPending()
#7 src/vendor/guzzlehttp/promises/src/Promise.php(226): GuzzleHttp\Promise\Promise->invokeWaitList()
#8 src/vendor/guzzlehttp/promises/src/Promise.php(62): GuzzleHttp\Promise\Promise->waitIfPending()
#9 src/vendor/guzzlehttp/guzzle/src/Client.php(131): GuzzleHttp\Promise\Promise->wait()
#10 src/vendor/guzzlehttp/guzzle/src/Client.php(89): GuzzleHttp\Client->request('get', 'https://www.goo...', Array)
#11 src/XF/Sitemap/Builder.php(508): GuzzleHttp\Client->__call('get', Array)
#12 src/XF/Sitemap/Builder.php(432): XF\Sitemap\Builder->sendPing()
#13 src/XF/Sitemap/Builder.php(73): XF\Sitemap\Builder->completeBuild()
#14 src/XF/Job/Sitemap.php(27): XF\Sitemap\Builder->build(2.79395)
#15 src/XF/Job/Manager.php(260): XF\Job\Sitemap->run(8)
#16 src/XF/Job/Manager.php(202): XF\Job\Manager->runJobInternal(Array, 8)
#17 src/XF/Job/Manager.php(118): XF\Job\Manager->runJobEntry(Array, 8)
#18 src/XF/Admin/Controller/Tools.php(122): XF\Job\Manager->runByIds(Array, 8)
#19 src/XF/Mvc/Dispatcher.php(352): XF\Admin\Controller\Tools->actionRunJob(Object(XF\Mvc\ParameterBag))
#20 src/XF/Mvc/Dispatcher.php(259): XF\Mvc\Dispatcher->dispatchClass('XF:Tools', 'RunJob', Object(XF\Mvc\RouteMatch), Object(ThemeHouse\UserCriteria\XF\Admin\Controller\Tools), NULL)
#21 src/XF/Mvc/Dispatcher.php(115): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(ThemeHouse\UserCriteria\XF\Admin\Controller\Tools), NULL)
#22 src/XF/Mvc/Dispatcher.php(57): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#23 src/XF/App.php(2351): XF\Mvc\Dispatcher->run()
#24 src/XF.php(517): XF\App->run()
#25 admin.php(13): XF::runApp('XF\\Admin\\App')
#26 {main}
Request state
array(4) {
  ["url"] => string(24) "/admin.php?tools/run-job"
  ["referrer"] => string(120) "https://www.joyfreak.com/admin.php?tools/run-job&only_id=104412&_xfRedirect=%2Fadmin.php%3Ftools%2Frebuild%26success%3D1"
  ["_GET"] => array(1) {
    ["tools/run-job"] => string(0) ""
  }
  ["_POST"] => array(3) {
    ["_xfRedirect"] => string(58) "https://www.joyfreak.com/admin.php?tools/rebuild&success=1"
    ["_xfToken"] => string(8) "********"
    ["only_ids"] => string(6) "104412"
  }
}
 
Solution
So to be clear this is an issue solely on the Bing end and can be safely ignored.

I don’t know how you go about reporting issues to Bing but it’s likely that enough people need to make them aware and hopefully that will prompt them to turn it off and on again.

Hopefully this isn't a planned closure of the sitemap ping endpoint. If it is, I can't see it documented anywhere...

It seems Bing are going all-in on their IndexNow protocol but I can't see them doing away with sitemaps just yet.

Does anyone actually have a Bing Webmaster Tools account? If so, please open a ticket or send them an email regarding this or please look for any further clues about what might be going on.

Cheers :)

Chris D

XenForo developer
Staff member
This URL seems to still work

Code:
https://bing.com/webmaster/ping.aspx?sitemap=https://z22se.co.uk/sitemap.xml
I noticed this too but, technically, that's the old URL. Presumably it may be shutdown at some point.

The ping URLs are customisable in your sitemap options so as a workaround you can replace the Bing one with:

Code:
https://bing.com/webmaster/ping.aspx?sitemap={$url}

...but if the current one starts working I'd recommend putting that one back.
 
Last edited:

AndyB

Well-known member
I submitted my sitemap through the Bing Webmaster Tools -> Submit Sitemap function manually, but after processing it returned with an "error" message.
 

Mendalla

Well-known member
I've had the 410 one twice, latest at 1:39am this morning. Noticed it the other day but it was Christmas and doesn't break anything on the site so wasn't too fussed. Figured I would find something on here if it was a bigger problem.
 

htsumer

Active member
I noticed this too but, technically, that's the old URL. Presumably it may be shutdown at some point.

The ping URLs are customisable in your sitemap options so as a workaround you can replace the Bing one with:

Code:
https://bing.com/webmaster/ping.aspx?sitemap={url}

...but if the current one starts working I'd recommend putting that one back.
Thank You

1640618032782.png

I did the check too, thanked bing :)
 
Top