XF 2.2 Error submitting sitemap to Bing

JoyFreak

Well-known member
Just had this error logged in the Admin CP. It only occurred once, earlier today. Any concerns or can be ignored?
Code:
Server error log
GuzzleHttp\Exception\ClientException: Error submitting sitemap to https://www.google.com/webmasters/tools/ping?sitemap=https%3A%2F%2Fwww.joyfreak.com%2Fsitemap.php: Client error: `GET https://www.google.com/webmasters/tools/ping?sitemap=https%3A%2F%2Fwww.joyfreak.com%2Fsitemap.php` resulted in a `429 Too Many Requests` response: <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> <html> <head><meta http-equiv="content-type" content="te (truncated...) src/vendor/guzzlehttp/guzzle/src/Exception/RequestException.php:113
Generated by: Unknown account Dec 13, 2021 at 8:22 AM
Stack trace
#0 src/vendor/guzzlehttp/guzzle/src/Middleware.php(66): GuzzleHttp\Exception\RequestException::create(Object(GuzzleHttp\Psr7\Request), Object(GuzzleHttp\Psr7\Response))
#1 src/vendor/guzzlehttp/promises/src/Promise.php(204): GuzzleHttp\Middleware::GuzzleHttp\{closure}(Object(GuzzleHttp\Psr7\Response))
#2 src/vendor/guzzlehttp/promises/src/Promise.php(153): GuzzleHttp\Promise\Promise::callHandler(1, Object(GuzzleHttp\Psr7\Response), NULL)
#3 src/vendor/guzzlehttp/promises/src/TaskQueue.php(48): GuzzleHttp\Promise\Promise::GuzzleHttp\Promise\{closure}()
#4 src/vendor/guzzlehttp/promises/src/Promise.php(248): GuzzleHttp\Promise\TaskQueue->run(true)
#5 src/vendor/guzzlehttp/promises/src/Promise.php(224): GuzzleHttp\Promise\Promise->invokeWaitFn()
#6 src/vendor/guzzlehttp/promises/src/Promise.php(269): GuzzleHttp\Promise\Promise->waitIfPending()
#7 src/vendor/guzzlehttp/promises/src/Promise.php(226): GuzzleHttp\Promise\Promise->invokeWaitList()
#8 src/vendor/guzzlehttp/promises/src/Promise.php(62): GuzzleHttp\Promise\Promise->waitIfPending()
#9 src/vendor/guzzlehttp/guzzle/src/Client.php(131): GuzzleHttp\Promise\Promise->wait()
#10 src/vendor/guzzlehttp/guzzle/src/Client.php(89): GuzzleHttp\Client->request('get', 'https://www.goo...', Array)
#11 src/XF/Sitemap/Builder.php(508): GuzzleHttp\Client->__call('get', Array)
#12 src/XF/Sitemap/Builder.php(432): XF\Sitemap\Builder->sendPing()
#13 src/XF/Sitemap/Builder.php(73): XF\Sitemap\Builder->completeBuild()
#14 src/XF/Job/Sitemap.php(27): XF\Sitemap\Builder->build(2.79395)
#15 src/XF/Job/Manager.php(260): XF\Job\Sitemap->run(8)
#16 src/XF/Job/Manager.php(202): XF\Job\Manager->runJobInternal(Array, 8)
#17 src/XF/Job/Manager.php(118): XF\Job\Manager->runJobEntry(Array, 8)
#18 src/XF/Admin/Controller/Tools.php(122): XF\Job\Manager->runByIds(Array, 8)
#19 src/XF/Mvc/Dispatcher.php(352): XF\Admin\Controller\Tools->actionRunJob(Object(XF\Mvc\ParameterBag))
#20 src/XF/Mvc/Dispatcher.php(259): XF\Mvc\Dispatcher->dispatchClass('XF:Tools', 'RunJob', Object(XF\Mvc\RouteMatch), Object(ThemeHouse\UserCriteria\XF\Admin\Controller\Tools), NULL)
#21 src/XF/Mvc/Dispatcher.php(115): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(ThemeHouse\UserCriteria\XF\Admin\Controller\Tools), NULL)
#22 src/XF/Mvc/Dispatcher.php(57): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#23 src/XF/App.php(2351): XF\Mvc\Dispatcher->run()
#24 src/XF.php(517): XF\App->run()
#25 admin.php(13): XF::runApp('XF\\Admin\\App')
#26 {main}
Request state
array(4) {
  ["url"] => string(24) "/admin.php?tools/run-job"
  ["referrer"] => string(120) "https://www.joyfreak.com/admin.php?tools/run-job&only_id=104412&_xfRedirect=%2Fadmin.php%3Ftools%2Frebuild%26success%3D1"
  ["_GET"] => array(1) {
    ["tools/run-job"] => string(0) ""
  }
  ["_POST"] => array(3) {
    ["_xfRedirect"] => string(58) "https://www.joyfreak.com/admin.php?tools/rebuild&success=1"
    ["_xfToken"] => string(8) "********"
    ["only_ids"] => string(6) "104412"
  }
}
 
Solution
So to be clear this is an issue solely on the Bing end and can be safely ignored.

I don’t know how you go about reporting issues to Bing but it’s likely that enough people need to make them aware and hopefully that will prompt them to turn it off and on again.

Hopefully this isn't a planned closure of the sitemap ping endpoint. If it is, I can't see it documented anywhere...

It seems Bing are going all-in on their IndexNow protocol but I can't see them doing away with sitemaps just yet.

Does anyone actually have a Bing Webmaster Tools account? If so, please open a ticket or send them an email regarding this or please look for any further clues about what might be going on.

Cheers :)

Chris D

XenForo developer
Staff member
So to be clear this is an issue solely on the Bing end and can be safely ignored.

I don’t know how you go about reporting issues to Bing but it’s likely that enough people need to make them aware and hopefully that will prompt them to turn it off and on again.

Hopefully this isn't a planned closure of the sitemap ping endpoint. If it is, I can't see it documented anywhere...

It seems Bing are going all-in on their IndexNow protocol but I can't see them doing away with sitemaps just yet.

Does anyone actually have a Bing Webmaster Tools account? If so, please open a ticket or send them an email regarding this or please look for any further clues about what might be going on.

Cheers :)
 
Solution

Chris D

XenForo developer
Staff member
This URL seems to still work

Code:
https://bing.com/webmaster/ping.aspx?sitemap=https://z22se.co.uk/sitemap.xml
I noticed this too but, technically, that's the old URL. Presumably it may be shutdown at some point.

The ping URLs are customisable in your sitemap options so as a workaround you can replace the Bing one with:

Code:
https://bing.com/webmaster/ping.aspx?sitemap={$url}

...but if the current one starts working I'd recommend putting that one back.
 
Last edited:

Chris D

XenForo developer
Staff member
The sitemap always works. It's always there and search engines still know where to find it. The "ping" which tells Bing that it has been updated does not work, but also, for the reasons mentioned, probably doesn't cause any issue. It can be safely ignored.
 

JoyFreak

Well-known member
Can someone explain, does the sitemap still work intermittently on the days there are no errors? I got another error yesterday as well.
It will produce an error every time the cron runs to rebuild the sitemap, which isn’t daily, it’s every few days if you haven’t edited it.
 

gerryvz

Well-known member
Since changing the Bing submission URL to the one specified by @Chris D, have had NO MORE SUBMISSION ERRORS. This for two different XenForo forums.

I highly recommend that folks just change the damn URL, and stop complaining. That solves the problem, and the fix takes all of 1 minute.
 

Chris D

XenForo developer
Staff member
Why is changing the ping URL as seen below only considered a workaround? Does it still function as intended and submit the ping for the sitemap or does it just avoid getting the server log error message?
The workaround URL is not the URL that Bing advise using in their documentation. In fact, it's the old URL before it changed to what it is at the moment. While it doesn't generate an error, we actually have no idea whether it works or not, nor whether or not Bing will eventually shut that one down.

Also, what is the $ removed on the workaround URL?
This is a mistake.

It should be:
Code:
https://bing.com/webmaster/ping.aspx?sitemap={$url}

@webbouk I think you attempted to bring this to my attention already and I dismissed it, sorry about that.
 

Tom McIntyre

Active member
Apparently Bing, Yandex and perhaps some other indexing services want to fix the excess processing that the current sitemap usage creates. At least that is what they seem to claim. https://www.indexnow.org/ is the site of the new activity to consolidate sitemap management among the indexers to improve the handling of changes to exisiting indexed content.

There is documentation and FAQ's at that URL.

This article discusses this from the Bing and Yandex point of view. https://www.ctrl.blog/entry/sitemap-ping-indexnow.html
 
Last edited:

Brogan

XenForo moderator
Staff member
 

PaulProe

Member
This morning, we woke up to a Bing sitemap error "410 Gone" Is this something to ignore or is it an issue?

This is the server error data:
Code:
GuzzleHttp\Exception\ClientException: Error submitting sitemap to https://www.bing.com/ping?sitemap=https%3A%2F%2Fgatewaycobraclub.com%2Fforum%2Fsitemap.php: Client error: `GET https://www.bing.com/ping?sitemap=https%3A%2F%2Fgatewaycobraclub.com%2Fforum%2Fsitemap.php` resulted in a `410 Gone` response src/vendor/guzzlehttp/guzzle/src/Exception/RequestException.php:113
Generated by: Unknown account Dec 22, 2021 at 6:12 AM
Stack trace
#0 src/vendor/guzzlehttp/guzzle/src/Middleware.php(66): GuzzleHttp\Exception\RequestException::create(Object(GuzzleHttp\Psr7\Request), Object(GuzzleHttp\Psr7\Response))
#1 src/vendor/guzzlehttp/promises/src/Promise.php(204): GuzzleHttp\Middleware::GuzzleHttp\{closure}(Object(GuzzleHttp\Psr7\Response))
#2 src/vendor/guzzlehttp/promises/src/Promise.php(153): GuzzleHttp\Promise\Promise::callHandler(1, Object(GuzzleHttp\Psr7\Response), NULL)
#3 src/vendor/guzzlehttp/promises/src/TaskQueue.php(48): GuzzleHttp\Promise\Promise::GuzzleHttp\Promise\{closure}()
#4 src/vendor/guzzlehttp/promises/src/Promise.php(248): GuzzleHttp\Promise\TaskQueue->run(true)
#5 src/vendor/guzzlehttp/promises/src/Promise.php(224): GuzzleHttp\Promise\Promise->invokeWaitFn()
#6 src/vendor/guzzlehttp/promises/src/Promise.php(269): GuzzleHttp\Promise\Promise->waitIfPending()
#7 src/vendor/guzzlehttp/promises/src/Promise.php(226): GuzzleHttp\Promise\Promise->invokeWaitList()
#8 src/vendor/guzzlehttp/promises/src/Promise.php(62): GuzzleHttp\Promise\Promise->waitIfPending()
#9 src/vendor/guzzlehttp/guzzle/src/Client.php(131): GuzzleHttp\Promise\Promise->wait()
#10 src/vendor/guzzlehttp/guzzle/src/Client.php(89): GuzzleHttp\Client->request('get', 'https://www.bin...', Array)
#11 src/XF/Sitemap/Builder.php(508): GuzzleHttp\Client->__call('get', Array)
#12 src/XF/Sitemap/Builder.php(432): XF\Sitemap\Builder->sendPing()
#13 src/XF/Sitemap/Builder.php(73): XF\Sitemap\Builder->completeBuild()
#14 src/XF/Job/Sitemap.php(27): XF\Sitemap\Builder->build(1.27531)
#15 src/XF/Job/Manager.php(260): XF\Job\Sitemap->run(7.98842)
#16 src/XF/Job/Manager.php(202): XF\Job\Manager->runJobInternal(Array, 7.98842)
#17 src/XF/Job/Manager.php(86): XF\Job\Manager->runJobEntry(Array, 7.98842)
#18 job.php(43): XF\Job\Manager->runQueue(false, 8)
#19 {main}
Request state
array(4) {
  ["url"] => string(14) "/forum/job.php"
  ["referrer"] => string(65) "https://gatewaycobraclub.com/forum/index.php?whats-new/posts/219/"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
 

JoyFreak

Well-known member
Hi,
Now I'm getting this spammed in my logs when sitemap submits. Any idea what it could be?
Code:
Server error log
GuzzleHttp\Exception\ClientException: Error submitting sitemap to https://www.bing.com/ping?sitemap=https%3A%2F%2Fwww.joyfreak.com%2Fsitemap.php: Client error: `GET https://www.bing.com/ping?sitemap=https%3A%2F%2Fwww.joyfreak.com%2Fsitemap.php` resulted in a `410 Gone` response src/vendor/guzzlehttp/guzzle/src/Exception/RequestException.php:113
Generated by: Unknown account Dec 22, 2021 at 9:58 PM
Stack trace
#0 src/vendor/guzzlehttp/guzzle/src/Middleware.php(66): GuzzleHttp\Exception\RequestException::create(Object(GuzzleHttp\Psr7\Request), Object(GuzzleHttp\Psr7\Response))
#1 src/vendor/guzzlehttp/promises/src/Promise.php(204): GuzzleHttp\Middleware::GuzzleHttp\{closure}(Object(GuzzleHttp\Psr7\Response))
#2 src/vendor/guzzlehttp/promises/src/Promise.php(153): GuzzleHttp\Promise\Promise::callHandler(1, Object(GuzzleHttp\Psr7\Response), NULL)
#3 src/vendor/guzzlehttp/promises/src/TaskQueue.php(48): GuzzleHttp\Promise\Promise::GuzzleHttp\Promise\{closure}()
#4 src/vendor/guzzlehttp/promises/src/Promise.php(248): GuzzleHttp\Promise\TaskQueue->run(true)
#5 src/vendor/guzzlehttp/promises/src/Promise.php(224): GuzzleHttp\Promise\Promise->invokeWaitFn()
#6 src/vendor/guzzlehttp/promises/src/Promise.php(269): GuzzleHttp\Promise\Promise->waitIfPending()
#7 src/vendor/guzzlehttp/promises/src/Promise.php(226): GuzzleHttp\Promise\Promise->invokeWaitList()
#8 src/vendor/guzzlehttp/promises/src/Promise.php(62): GuzzleHttp\Promise\Promise->waitIfPending()
#9 src/vendor/guzzlehttp/guzzle/src/Client.php(131): GuzzleHttp\Promise\Promise->wait()
#10 src/vendor/guzzlehttp/guzzle/src/Client.php(89): GuzzleHttp\Client->request('get', 'https://www.bin...', Array)
#11 src/XF/Sitemap/Builder.php(508): GuzzleHttp\Client->__call('get', Array)
#12 src/XF/Sitemap/Builder.php(432): XF\Sitemap\Builder->sendPing()
#13 src/XF/Sitemap/Builder.php(73): XF\Sitemap\Builder->completeBuild()
#14 src/XF/Job/Sitemap.php(27): XF\Sitemap\Builder->build(5.05514)
#15 src/XF/Job/Manager.php(260): XF\Job\Sitemap->run(8)
#16 src/XF/Job/Manager.php(202): XF\Job\Manager->runJobInternal(Array, 8)
#17 src/XF/Job/Manager.php(118): XF\Job\Manager->runJobEntry(Array, 8)
#18 src/XF/Admin/Controller/Tools.php(122): XF\Job\Manager->runByIds(Array, 8)
#19 src/XF/Mvc/Dispatcher.php(352): XF\Admin\Controller\Tools->actionRunJob(Object(XF\Mvc\ParameterBag))
#20 src/XF/Mvc/Dispatcher.php(259): XF\Mvc\Dispatcher->dispatchClass('XF:Tools', 'RunJob', Object(XF\Mvc\RouteMatch), Object(ThemeHouse\UserCriteria\XF\Admin\Controller\Tools), NULL)
#21 src/XF/Mvc/Dispatcher.php(115): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(ThemeHouse\UserCriteria\XF\Admin\Controller\Tools), NULL)
#22 src/XF/Mvc/Dispatcher.php(57): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#23 src/XF/App.php(2351): XF\Mvc\Dispatcher->run()
#24 src/XF.php(517): XF\App->run()
#25 admin.php(13): XF::runApp('XF\\Admin\\App')
#26 {main}
Request state
array(4) {
  ["url"] => string(24) "/admin.php?tools/run-job"
  ["referrer"] => string(120) "https://www.joyfreak.com/admin.php?tools/run-job&only_id=106229&_xfRedirect=%2Fadmin.php%3Ftools%2Frebuild%26success%3D1"
  ["_GET"] => array(1) {
    ["tools/run-job"] => string(0) ""
  }
  ["_POST"] => array(3) {
    ["_xfRedirect"] => string(58) "https://www.joyfreak.com/admin.php?tools/rebuild&success=1"
    ["_xfToken"] => string(8) "********"
    ["only_ids"] => string(6) "106229"
  }
}
 

swiftyste

Active member
Hi,
Now I'm getting this spammed in my logs when sitemap submits. Any idea what it could be?
Code:
Server error log
GuzzleHttp\Exception\ClientException: Error submitting sitemap to https://www.bing.com/ping?sitemap=https%3A%2F%2Fwww.joyfreak.com%2Fsitemap.php: Client error: `GET https://www.bing.com/ping?sitemap=https%3A%2F%2Fwww.joyfreak.com%2Fsitemap.php` resulted in a `410 Gone` response src/vendor/guzzlehttp/guzzle/src/Exception/RequestException.php:113
Generated by: Unknown account Dec 22, 2021 at 9:58 PM
Stack trace
#0 src/vendor/guzzlehttp/guzzle/src/Middleware.php(66): GuzzleHttp\Exception\RequestException::create(Object(GuzzleHttp\Psr7\Request), Object(GuzzleHttp\Psr7\Response))
#1 src/vendor/guzzlehttp/promises/src/Promise.php(204): GuzzleHttp\Middleware::GuzzleHttp\{closure}(Object(GuzzleHttp\Psr7\Response))
#2 src/vendor/guzzlehttp/promises/src/Promise.php(153): GuzzleHttp\Promise\Promise::callHandler(1, Object(GuzzleHttp\Psr7\Response), NULL)
#3 src/vendor/guzzlehttp/promises/src/TaskQueue.php(48): GuzzleHttp\Promise\Promise::GuzzleHttp\Promise\{closure}()
#4 src/vendor/guzzlehttp/promises/src/Promise.php(248): GuzzleHttp\Promise\TaskQueue->run(true)
#5 src/vendor/guzzlehttp/promises/src/Promise.php(224): GuzzleHttp\Promise\Promise->invokeWaitFn()
#6 src/vendor/guzzlehttp/promises/src/Promise.php(269): GuzzleHttp\Promise\Promise->waitIfPending()
#7 src/vendor/guzzlehttp/promises/src/Promise.php(226): GuzzleHttp\Promise\Promise->invokeWaitList()
#8 src/vendor/guzzlehttp/promises/src/Promise.php(62): GuzzleHttp\Promise\Promise->waitIfPending()
#9 src/vendor/guzzlehttp/guzzle/src/Client.php(131): GuzzleHttp\Promise\Promise->wait()
#10 src/vendor/guzzlehttp/guzzle/src/Client.php(89): GuzzleHttp\Client->request('get', 'https://www.bin...', Array)
#11 src/XF/Sitemap/Builder.php(508): GuzzleHttp\Client->__call('get', Array)
#12 src/XF/Sitemap/Builder.php(432): XF\Sitemap\Builder->sendPing()
#13 src/XF/Sitemap/Builder.php(73): XF\Sitemap\Builder->completeBuild()
#14 src/XF/Job/Sitemap.php(27): XF\Sitemap\Builder->build(5.05514)
#15 src/XF/Job/Manager.php(260): XF\Job\Sitemap->run(8)
#16 src/XF/Job/Manager.php(202): XF\Job\Manager->runJobInternal(Array, 8)
#17 src/XF/Job/Manager.php(118): XF\Job\Manager->runJobEntry(Array, 8)
#18 src/XF/Admin/Controller/Tools.php(122): XF\Job\Manager->runByIds(Array, 8)
#19 src/XF/Mvc/Dispatcher.php(352): XF\Admin\Controller\Tools->actionRunJob(Object(XF\Mvc\ParameterBag))
#20 src/XF/Mvc/Dispatcher.php(259): XF\Mvc\Dispatcher->dispatchClass('XF:Tools', 'RunJob', Object(XF\Mvc\RouteMatch), Object(ThemeHouse\UserCriteria\XF\Admin\Controller\Tools), NULL)
#21 src/XF/Mvc/Dispatcher.php(115): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(ThemeHouse\UserCriteria\XF\Admin\Controller\Tools), NULL)
#22 src/XF/Mvc/Dispatcher.php(57): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#23 src/XF/App.php(2351): XF\Mvc\Dispatcher->run()
#24 src/XF.php(517): XF\App->run()
#25 admin.php(13): XF::runApp('XF\\Admin\\App')
#26 {main}
Request state
array(4) {
  ["url"] => string(24) "/admin.php?tools/run-job"
  ["referrer"] => string(120) "https://www.joyfreak.com/admin.php?tools/run-job&only_id=106229&_xfRedirect=%2Fadmin.php%3Ftools%2Frebuild%26success%3D1"
  ["_GET"] => array(1) {
    ["tools/run-job"] => string(0) ""
  }
  ["_POST"] => array(3) {
    ["_xfRedirect"] => string(58) "https://www.joyfreak.com/admin.php?tools/rebuild&success=1"
    ["_xfToken"] => string(8) "********"
    ["only_ids"] => string(6) "106229"
  }
}
Who knows but your not the only one i and another guy is facing the same issue

 
Top