1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error rebuilding templates

Discussion in 'Troubleshooting and Problems' started by Andy.N, May 10, 2012.

  1. Andy.N

    Andy.N Well-Known Member

    Move my site to a new folder and it looks like I need to set the permission correctly. Can anyone point me to the right direction?
    I got this error when I install/upgrade addons.

    file_put_contents(/home/andy/public_html/cn.quantnet/html/internal_data/templates/S.0,L.0,account.css.php): failed to open stream: Permission denied
    1. XenForo_Application::handlePhpError()
    2. file_put_contents() in XenForo/Template/FileHandler.php at line 95
    3. XenForo_Template_FileHandler->_saveTemplate() in XenForo/Template/FileHandler.php at line 50
    4. XenForo_Template_FileHandler::save() in XenForo/Model/Template.php at line 1090
    5. XenForo_Model_Template->compileAndInsertParsedTemplate() in TMS/Model/Template.php at line 178
    6. TMS_Model_Template->compileAndInsertParsedTemplate() in XenForo/Model/Template.php at line 1014
    7. XenForo_Model_Template->compileTemplateInStyleTree() in XenForo/Model/Template.php at line 968
    8. XenForo_Model_Template->compileNamedTemplateInStyleTree() in XenForo/Model/Template.php at line 925
    9. XenForo_Model_Template->compileAllTemplates() in TMS/Model/Template.php at line 116
    10. TMS_Model_Template->compileAllTemplates() in XenForo/CacheRebuilder/Template.php at line 55
    11. XenForo_CacheRebuilder_Template->rebuild() in XenForo/ControllerHelper/CacheRebuild.php at line 26
    12. XenForo_ControllerHelper_CacheRebuild->rebuildCache() in XenForo/ControllerAdmin/Tools.php at line 78
    13. XenForo_ControllerAdmin_Tools->actionCacheRebuild() in XenForo/FrontController.php at line 310
    14. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    15. XenForo_FrontController->run() in /home/andy/public_html/cn.quantnet/html/admin.php at line 13
  2. Deebs

    Deebs Well-Known Member

    Check your PM Andy.
  3. Andy.N

    Andy.N Well-Known Member

    Deebs fixed it before I finish posting this.
    Thanks Deebs.
  4. TheBigK

    TheBigK Well-Known Member

    What's the fix? I'm getting a similar error on my test server.
  5. Deebs

    Deebs Well-Known Member

    The permissions on the output directory were set incorrectly for the user running the PHP processes, basically, that user had no permissions to write to the directories.
  6. TheBigK

    TheBigK Well-Known Member

    On my test server, everything was working fine and the error popped up automatically when I tried to upgrade an add-on. What could change the user permissions on the server?

    I'm checking my server again.
  7. TheBigK

    TheBigK Well-Known Member

    @Mike Edge : Need your help here. The error occurred only when we manually launched apache (on the clone server, LightSpeed didn't run because it had a different IP).

    I tried installing our test add-on with LightSpeed running (on our live server); and it ran without issues.

    My web hosting guys are inspecting the PHP handler, which is DSO, and I think it requires different permissions than SuPHP.

    PS: All of the above is super confusing to me. Would really appreciate your help decoding this one.
  8. The Forum Heroes

    The Forum Heroes Well-Known Member

    Try FCGI, not DSO

Share This Page