error on ip.board import

Max Hodges

Member
I get an error when trying to validate the configurator

The source database connection details are not correct: Access denied for user 'dbo142309622'@'localhost'

my ip.board is MySQL4.0. SHould I try upgrading the db to v5 first?
 

Nasr

Well-known member
XenForo System Requirements

  • PHP: 5.2.4+
  • MySQL: 5.0+
  • PHP extensions: MySQLi, GD (with JPEG support), PCRE, SPL, SimpleXML, DOM, JSON, iconv, ctype
  • PHP safe_mode off
Download the requirements test script.

Try running that test script and make sure your database user and password are correct.
 

Brogan

XenForo moderator
Staff member
The error details seem to indicate you entered an incorrect username or password for the IP.Board database.

Have you confirmed they are the same as in the config.php (or equivalent) file?
 

Max Hodges

Member
I think the problem is that your code is [still] not supporting sockets. Every time i upgrade I have to make a manual patch per this thread:
http://xenforo.com/community/threads/1-1-denied-access-to-the-database.5125/#post-81385

so in the current situation, the xenforo data is using socket, but the ip.board database I want to import is not. So the import routine can't handle this situation. I'll look at first importing the ip.board data into a database which uses '/tmp/mysql5.sock' just like my xenforo install.
 

Jake Bunce

XenForo moderator
Staff member
I think the problem is that your code is [still] not supporting sockets. Every time i upgrade I have to make a manual patch per this thread:
http://xenforo.com/community/threads/1-1-denied-access-to-the-database.5125/#post-81385
Have you tried specifying the socket in the host parameter? I know this works for mysql_connect:

server

The MySQL server. It can also include a port number. e.g. "hostname:port" or a path to a local socket e.g. ":/path/to/socket" for the localhost.

If the PHP directive mysql.default_host is undefined (default), then the default value is 'localhost:3306'. In SQL safe mode, this parameter is ignored and value 'localhost:3306' is always used.
This isn't specified for mysqli_real_connect, but it's worth a try.
 
Top