• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Error Message when uploading

#1
I keep getting this error message when I try to upload an image. When, I uncheck the "Use Flash Uploader" i also get an error message.
I am able to upload a profile image but I cant upload a jpg or txt file in new threads or as replies.
error message.JPG error message 2.JPG
I tried reading up on the issue and i made sure that folders "internal_data" and "data" had permission to edit. It was set to 0755 but I now have it on 0777 for both of those two folders and their sub folders.

The permissions for the nodes and user groups are set to allow for uploading and viewing attachments.

I have the following add-ons installed
Book Reviews by Waindigo 1.0
Sitemap for XenForo 1.1.2
Social Beta 2
Template Modification System 1.1.1
Thread Thumbnails by Waindigo 1.2.3
[8wayRun.Com] XenMedio (Media) 1.5.0
[8wayRun.Com] XenPorta (Portal) 1.5.3
[******] Custom Node Icon 0.9

What can I do to fix my issue?
 

Jake Bunce

XenForo moderator
Staff member
#2
If not file permissions then perhaps a problem with your image library or the individual attachment.

What image library?

Admin CP -> Home -> Options -> Attachments -> Default Image Processor

Are you able to upload the same image here on this forum?

Also, can you post the URL to your forum so I can test it?
 

Jake Bunce

XenForo moderator
Staff member
#4
I have confirmed the problem. I can take a closer look if you give me FTP / admin access. Just respond to the PM you already sent me.
 

CurveGotti

Active member
#7
Not sure if Jake already solved this for you guys, but I know that on one particular shared server I was working with XenForo on the hosting company had modSecurity enabled and it was causing a similar error.
 
#8
I got it to work now by deleting the text in the attachments htaccess file found here: public_html/attachments/.htaccess

I deleted all of the text below, and it has no problem now.
#<Files *>
Order Deny,Allow
Deny from all
Allow from localhost
</Files>

#RemoveHandler .php .php3 .phtml .cgi .fcgi .pl .fpl .shtml