1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Duplicate Error at step 2b and no button

Discussion in 'Resolved Bug Reports' started by dutchbb, Oct 6, 2010.

  1. dutchbb

    dutchbb Well-Known Member

  2. RickM

    RickM Well-Known Member

    Already resolved and there are a large number of threads about it - download again and re-upload the /js directory and it'll fix it :)
    dutchbb likes this.
  3. Hannah_M

    Hannah_M Active Member

    I checked the js file on your server and it still says timeout: 2000. Did you try to change it to 30000?
  4. dutchbb

    dutchbb Well-Known Member

    Strange didn't find threads about it. So the download package has already changed?

    Ok I'll try the new package then.
  5. jmurrayhead

    jmurrayhead Well-Known Member

    Not already resolved for everyone. I'm still getting the same error after the fix.
  6. dutchbb

    dutchbb Well-Known Member

    New package solved the issue for me. Thanks RickM.
  7. Erik

    Erik Well-Known Member

    Same here. Regardless, I just let it be and it appeared to install successfully after a few minutes. :)

    Edit: I may not have the new package. Give me a second. :)
  8. calorie

    calorie Active Member

    Is the browser still working even though you see that error message on screen? If so, try waiting for the browser to redirect you to step three and ignore the error. Do not stop your browser from working. Go have a smoke or something :) and return in a bit, and hopefully you find that XF proceeded to step three, no harm done.
  9. Stryker

    Stryker Member

    I've just decided to add another 0 after the 30000 and that seemed to work
  10. jmurrayhead

    jmurrayhead Well-Known Member

    I have waited for it to finish and it did, sometimes giving what looks like a stack trace. I've also tried refreshing after that. Still no joy :(
  11. Stryker

    Stryker Member

    yea, I can now confirm it works, I've done it on 3 test installations where you do this:

    Open file js/xenforo/cache_rebuild.js
        { error: $.context(this, 'formSubmitError'), timeout: 30000 }
    and change to
        { error: $.context(this, 'formSubmitError'), timeout: 300000 }
  12. Floris

    Floris Guest

    Re-download the .zip :)
  13. jmurrayhead

    jmurrayhead Well-Known Member

    adding the extra zer0 at least gave me the "Rebuild Caches" button. Just waiting on that to finish now.
  14. jmurrayhead

    jmurrayhead Well-Known Member

    I've done that already...still no luck :/
  15. Stryker

    Stryker Member

    Let me know how it goes jmurrayhead it seems to work on my Fedora 13 VPS and on my own localhost
  16. jmurrayhead

    jmurrayhead Well-Known Member

    lol I click the "Rebuild Caches" button and after a long wait, Firefox asks me if I want to save index.php :rolleyes: GoDaddy frustrates the piss outta me. I've been meaning to get my own VPS...
  17. Erik

    Erik Well-Known Member

    I re-downloaded the zip and it only gave me the error once, which is better than it was. Still installs successfully, although it does seem to take a while. :)
  18. jmurrayhead

    jmurrayhead Well-Known Member

    Hmm.. still can't get any further than Rebuilding... Phrases (importing)

    Now I'm getting this error:

    the error varies between the previous posted and the following during step 2b:

    Server Error

    Mysqli statement execute error : Query execution was interrupted

    1. Zend_Db_Statement_Mysqli->_execute() in /home/content/xxx/html/xf/library/Zend/Db/Statement.php at line 300
    2. Zend_Db_Statement->execute() in /home/content/xxx/html/xf/library/Zend/Db/Adapter/Abstract.php at line 468
    3. Zend_Db_Adapter_Abstract->query() in /home/content/xxx/html/xf/library/XenForo/Model/Phrase.php at line 992
    4. XenForo_Model_Phrase->deletePhrasesForAddOn() in /home/content/xxx/html/xf/library/XenForo/Model/Phrase.php at line 1022
    5. XenForo_Model_Phrase->importPhrasesAddOnXml() in /home/content/xxx/html/xf/library/XenForo/CacheRebuilder/ImportPhrase.php at line 33
    6. XenForo_CacheRebuilder_ImportPhrase->rebuild() in /home/content/xxx/html/xf/library/XenForo/ControllerHelper/CacheRebuild.php at line 26
    7. XenForo_ControllerHelper_CacheRebuild->rebuildCache() in /home/content/xxx/html/xf/library/XenForo/Install/Controller/Install.php at line 243
    8. XenForo_Install_Controller_Install->actionStep2b() in /home/content/xxx/html/xf/library/XenForo/FrontController.php at line 303
    9. XenForo_FrontController->dispatch() in /home/content/xxx/html/xf/library/XenForo/FrontController.php at line 132
    10. XenForo_FrontController->run() in /home/content/xxx/html/xf/install/index.php at line 17
  19. Erik

    Erik Well-Known Member

    Sounds like the script was killed because it was taking too long. Are you on a shared host?

    If not, try increasing PHP's max execution time, memory limit, or both. I'm not familiar enough with MySQL to know if it has a maximum query execution time, but if it does you could try increasing that as well. :)
  20. jmurrayhead

    jmurrayhead Well-Known Member

    Yes, unfortunately I am on a shared host :/ I've been thinking about getting a VPS for quite some time, and probably will soon, but XenForo still needs to work for those who will stay on shared hosting.

Share This Page