• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Server Error at Step 1b

#1
Hi Guys,

First time using XenForo and I have ran into an error in the Step 1b section of the installation. Any help would be much appreciated.

Server Error


  1. Zend_Db_Adapter_Mysqli->_connect() in Zend/Db/Adapter/Abstract.php at line 315
  2. Zend_Db_Adapter_Abstract->getConnection() in XenForo/Application.php at line 727
  3. XenForo_Application->loadDb()
  4. call_user_func_array() in XenForo/Application.php at line 968
  5. XenForo_Application->lazyLoad() in XenForo/Application.php at line 999
  6. XenForo_Application::get() in XenForo/Application.php at line 1569
  7. XenForo_Application::getDb() in XenForo/Model.php at line 161
  8. XenForo_Model->_getDb() in XenForo/Install/Model/Install.php at line 218
  9. XenForo_Install_Model_Install->hasApplicationTables() in XenForo/Install/Controller/Install.php at line 169
  10. XenForo_Install_Controller_Install->actionStep1b() in XenForo/FrontController.php at line 347
  11. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  12. XenForo_FrontController->run() in /websites/at/athleticsexclusive.com/marshalling/install/index.php at line 18
 

Jake Bunce

XenForo moderator
Staff member
#5
I replied to your ticket.

There isn't a specific error. But this appears to be a database connection error of some kind. Basically you need to confirm the MySQL information that you are entering into the first step of the install. Your web host should be able to confirm this information.

I suppose it could also be a lack of MySQLi support in PHP. The requirements script will test for this and other XF requirements:

https://xenforo.com/xenforo-requirements-test.zip