1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Install Error - Blank page for Step 2B

Discussion in 'Installation, Upgrade, and Import Support' started by RobParker, Oct 14, 2010.

  1. RobParker

    RobParker Well-Known Member

    I'm trying to install XF on a sub-domain of my site for testing and get a blank page when it gets to index.php?install/step/2b

    I've tried 3 times now (re-uploaded files, wiped database, etc) and it has the same problem every time.

    I ran the test script to verify all my server settings/sfotware were compatible and that ran fine.

    Any ideas?
     
  2. RobParker

    RobParker Well-Known Member

    I tried a completely fresh install on a different domain (so not a sub-domain) and at /install/index.php?install/step/2b it comes up with:

    Rebuilding...


    An error occurred. Please click the button below for more information.


    The only button below is "Rebuild Caches" and when I click that I get a blank page at install/index.php?install/step/2b
     
  3. Mike

    Mike XenForo Developer Staff Member

    There are a lot of fixes related to this area for beta 2, and I'm hopeful that they will resolve most issues.

    Do you know what the last text you saw was, before "an error occurred" appeared?
     
  4. RobParker

    RobParker Well-Known Member

    I believe it was "Rebuilding (phrases)"

    Just to say I've installed this locally on my iMac using MAMP and it installed fine so looks like it's something it didn't like on our server. Was a bit annoyed that I wasn't getting to play with it but now I can play locally I'm happy to wait until Beta 2 before trying to install on our server :)
     
  5. Mike

    Mike XenForo Developer Staff Member

    I've made some significant changes to the phrase rebuild system, so hopefully that will fix your problems.
     
    RobParker likes this.
  6. RobParker

    RobParker Well-Known Member

    Thanks

    Is there a rough time-frame for the next release? Obviously would rather it was fixed than rushed :)
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    :)
     
  8. RobParker

    RobParker Well-Known Member

    That was on Tuesday, does that mean by tomorrow or before the end of next week (22nd)?

    Sorry for the impatience, just XF is what I was hoping VB4 would be and quite excited by the possibilities :)
     
  9. Mike

    Mike XenForo Developer Staff Member

    That'd be referring to next week.
     
  10. RobParker

    RobParker Well-Known Member

  11. Hatsu

    Hatsu Member

    I experienced the same error. I couldn't click in the button below, because there wasn't any. I waited until xenforo error page was loaded, clicked the back button of my browser and the installation started with the rebuilding again and went through.
     
    RobParker likes this.
  12. RobParker

    RobParker Well-Known Member

    Still having a problem with the new release not installing :-(

    An error occurred. The request is being resubmitted.

    I clicked rebuild caches and it goes to a blank page at: install/index.php?install/step/2b
     
  13. Blandt

    Blandt Well-Known Member

    It's really hard to guess .. if you can give us the server log ..

    OS/server version . PHP and MySQL
     
  14. Mike

    Mike XenForo Developer Staff Member

    If you can provide me with FTP and admin access, I can try to debug this further.
     
  15. RobParker

    RobParker Well-Known Member

    CentOS release 5.5 (Final)
    PHP 5.2.10
    MySQL Version 5.0.77-log

    Will get server logs shortly.
     
  16. RobParker

    RobParker Well-Known Member

    error.log is empty

    I'm transferring everything to a test domain and if it still doesn't work will set up an ftp/db account for you.
     
  17. Blandt

    Blandt Well-Known Member

    I think this is a server configuration issue.. if you are installing on the same server most likely wyou are going to have the same problem
    Also upgrade MySQL.
     
  18. RobParker

    RobParker Well-Known Member

    Yep I suspect you're correct.

    I'll get on to our hosts and request that they upgrade MySQL but I was under the impression that the version we are running should be fine...?
     
  19. Blandt

    Blandt Well-Known Member

    The test script does not test the SQL server :) So that's the first thing we should look at :) if you have ssh access I can upgrade it for you, unless your host is super fast :)
     
  20. Brogan

    Brogan XenForo Moderator Staff Member

    There's a script here you can use to check your server: http://xenforo.com/community/threads/beta-release-date-and-pricing.3876/#post-63080

    However: "This script will confirm that you meet the PHP requirements. You will need to confirm the MySQL version requirement independently."
     

Share This Page