• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Enhanced Search broken?

#1
Enhanced Search seems to have issues. Using 1.1.4. Yesterday I deleted over 200 pages worth of server errors. Today, I have 24 pages again.

XenForo_Exception: Elasticsearch error: {"root_cause":[{"type":"parsing_exception","reason":"The field [fields] is no longer supported, please use [stored_fields] to retrieve stored fields or _source filtering if the field is not stored","line":1,"col":148}],"type":"parsing_exception","reason":"The field [fields] is no longer supported, please use [stored_fields] to retrieve stored fields or _source filtering if the field is not stored","line":1,"col":148} - library/XenES/Search/SourceHandler/ElasticSearch.php:894
Generated By: creativeforge, Today at 1:12 PM
Stack Trace
#0 /home/vicontr/public_html/community/library/XenES/Search/SourceHandler/ElasticSearch.php(348): XenES_Search_SourceHandler_ElasticSearch->_logSearchResponseError(Object(stdClass), true)
#1 /home/vicontr/public_html/community/library/XenForo/Search/SourceHandler/Abstract.php(115): XenES_Search_SourceHandler_ElasticSearch->executeSearch('technic', false, Array, Array, false, 500)
#2 /home/vicontr/public_html/community/library/XenForo/Search/Searcher.php(79): XenForo_Search_SourceHandler_Abstract->searchGeneral('technic', Array, 'date', '500')
#3 /home/vicontr/public_html/community/library/XenForo/ControllerPublic/Search.php(255): XenForo_Search_Searcher->searchGeneral('technic', Array, 'date')
#4 /home/vicontr/public_html/community/library/XenES/Proxy/ControllerSearch.php(30): XenForo_ControllerPublic_Search->actionSearch()
#5 /home/vicontr/public_html/community/library/XenForo/FrontController.php(351): XenES_Proxy_ControllerSearch->actionSearch()
#6 /home/vicontr/public_html/community/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#7 /home/vicontr/public_html/community/index.php(13): XenForo_FrontController->run()
#8 {main}
Request State
array(3) {
["url"] => string(45) "http://vi-control.net/community/search/search"
["_GET"] => array(0) {
}
["_POST"] => array(4) {
["keywords"] => string(7) "technic"
["users"] => string(0) ""
["date"] => string(0) ""
["_xfToken"] => string(8) "********"
}
}
I downloaded the upgrade to 1.1.6, but what do I do with this?

"It is important that the files on the server and what you're uploading are "merged". Otherwise you may break your XenForo installation."

What does "merge" mean and how do I do it?

Many thanks!

Andre
 

Chris D

XenForo developer
Staff member
#2
If you've ever updated XF or an add-on before then it's exactly the same process.

That update should fix the issue you're having.