Enhanced Search 1.1.8 -- maximum ElasticSearch version?

Wildcat Media

Well-known member
I'm in the process of preparing an older XF installation (running the last release of XF 1.5) for upgrade to 2.2.8, but wanted to bring the ElasticSearch to a more current version beforehand due to the Log4j issue. We have an instance of 6.8.20 running at the moment for our private testing and development forum. Would Enhanced Search 1.1.8 run on ES 6.8.20?
 

Chris D

XenForo developer
Staff member
The short answer is: I don't know.

The last version of Enhanced Search is 1.1.8 and that aimed to add compatibility with Elasticsearch 6.

At the time that was released, Elasticsearch 6.0.0 wasn't even generally available. So we can only really guarantee compatibility with Elasticsearch 6.0.0. We wouldn't have tested on any other version.

The only other comforting intel I can find is that I can't identify any Elasticsearch compatibility specific changes in any subsequent version of Enhanced Search either, until XFES 2.1.1 when we added support for Elasticsearch 7.0.

On that basis I'd think you'll be okay with any 6.x version but we'd recommend testing before committing.
 

Kirby

Well-known member
I can confirm that Enhanced Search 1.1.8 does work with ElasticSearch 6.8.20 (tested search & index), so I'd expect that it will also work with upcoming 6.8.21
 
Last edited:

Sim

Well-known member
I just spun up a new ES server for XFES 1.1.8 - my old one was running ElasticSearch 5.6.3 on Ubuntu 16.04 :eek:

New build on Ubuntu 20.04LTS automatically installed ElasticSearch 6.8.21 ... which also has the -Dlog4j2.formatMsgNoLookups=true option set by default - yay.

No errors on server yet - currently rebuilding search indexes.
 
Top