• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Email missing_domain

Dav

Active member
#1
Hi,

We are having problems with our emails that are being sent to our users. Instead of showing up as support@MyDomain.com it is going through to users as suppor@MISSING_DOMAIN. It was all fine up until about a week ago when i changed computers.

I have checked the software settings and the email address is set correctly.

Can anyone help with this?
 

Brogan

XenForo moderator
Staff member
#2
What do you mean by "changed computers"?
Did you switch hosts or move the install from one domain to another?

Is the Board URL set correctly in ACP -> Basic Board Information?
 

Dav

Active member
#3
Hi Brogan

I changed from one laptop to another. My old laptop broke. everything is on my old hard drive

This would not affect anything would it because all the installation files etc will be on the host server or will it?

sorry if this sounds silly im still learning :)
 

Brogan

XenForo moderator
Staff member
#4
No worries, we all have to start somewhere :)

Yes, that's correct.
Your PC/laptop has no bearing at all on your site as it is installed on your host's remote server (PC).

Have you made any changes, installed any add-ons, etc. prior to the problem starting?

Presumably though, and just to clarify, these emails are emails generated and sent by your forum for e.g. thread replies, etc?
Not emails you are personally sending from your PC?
 

Dav

Active member
#5
Hi Brogan,

IV not installed any add-ons etc

Yeh thats right they are emails generated by the forum. The emails are coming through fine but its just the sender address that is incorrect and im worried people will just see them as spam and dismiss them.
Iv checked in my host control panel to check all the settings are right for the email account and everything seems ok and iv sent a email to my host and he thinks it could be a setting in xenforo but all the settings in there seem ok. e.g email address, domain name etc.

Very strange because the emails are coming through as suppor@MISSING_DOMAIN. even with the miss spelling, but in the ACP settings it is spelt correctly.

Thanks :)
 

Brogan

XenForo moderator
Staff member
#6
What are you using as the email transport method, default or SMTP?

Can you try changing from one to the other and see if that has any effect?
 

Dav

Active member
#8
What are you using as the email transport method, default or SMTP?

Can you try changing from one to the other and see if that has any effect?
Hi Brogan,

I tried changing from default to SMTP but the problem is still the same people are recieving the emails but the sender is still suppor@MISSING_DOMAIN instead of support@mydomain.com
 

Brogan

XenForo moderator
Staff member
#9
Hmm, this seems like a bit of an odd one.

It's as if $fromEmail has somehow become corrupt or changed but I'm not sure how that could happen after it was working previously.

I'll flag this one to Mike as he will have a better idea of what might be causing this.
 

Dav

Active member
#10
Hmm, this seems like a bit of an odd one.

It's as if $fromEmail has somehow become corrupt or changed but I'm not sure how that could happen after it was working previously.

I'll flag this one to Mike as he will have a better idea of what might be causing this.
Thanks Brogan any help would be great :)
 

Brogan

XenForo moderator
Staff member
#11
Out of interest, what is the title field appearing as?
Is it My Domain or is that also not appearing correctly?
Or is it just appearing as the sender email address?
 

Mike

XenForo developer
Staff member
#12
A quick Google suggests that this might be a configuration issue with Dovecot, but I'm not sure.

Can you send me FTP access so I can look into this?
 

Dav

Active member
#14
A quick Google suggests that this might be a configuration issue with Dovecot, but I'm not sure.

Can you send me FTP access so I can look into this?
Hi Mike,

Did you manage to look into this email problem because my internal emails are still coming from suppor@MISSING_DOMAIN, i can send you the details again if you need me to

Thanks
 

Blandt

Well-known member
#17
If you are using Postfix have your host check the conf file
main.cf (on debain it's located at /etc/postfix/main.cf )

Make sure you have the default like this :
HTML:
   # Optional: send mail as user@domainname instead of user@hostname.
    myorigin = $mydomain

    # Optional: specify NAT/proxy external address.
    #proxy_interfaces = 1.2.3.4

    # Alternative 1: don't relay mail from other hosts.
    mynetworks_style = host
    relay_domains =

    # Alternative 2: relay mail from local clients only.
    # mynetworks = 192.168.1.0/28
    # relay_domains =
make sure the myorigin is not commented out ...
This is just a quick guess :D If you give us your server distro and what mail server you are using we can diagnose this better