1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Editor Issues

Discussion in 'Resolved Bug Reports' started by BamaStangGuy, Mar 21, 2013.

  1. BamaStangGuy

    BamaStangGuy Well-Known Member

    I just submitted a resource and ran into a frustrating issue.

    I want to insert an image at the end but before I did that I highlighted some text and made formatting changes to it.

    After the formatting was applied I hit enter a couple of times to add space. Then I inserted the image. It looked fine and I went through and submitted the resource.

    Now I go to edit it and it looks like this:

    Screen Shot 2013-03-20 at 9.44.47 PM.png

    I want to add something below the attached image so I place my cursor at the very end of the attach line. I hit enter. Nothing happens. It won't create a new line.

    That's beside the fact that the attach part is taking on the format of the text before it.

    This is what it looks like in plain text

    Screen Shot 2013-03-20 at 9.44.41 PM.png

    The editor of xenForo leaves so much to be desired. I miss vBulletin where you could disable WYSIWYG completely and still have all the options. Much like this: http://xenforo.com/community/resources/markitup-integrator-2013.1340/

    I guess this is primarily a bug report with a feature request at the end. I will create a new thread for the request.
    DRE likes this.
  2. Mike

    Mike XenForo Developer Staff Member

    If your using Chrome, try another browser - there is actually a Chrome bug that manifests in RTEs where it won't insert a line break in all cases. But in general, I'm hoping to resolve this by simply killing TinyMCE, so slightly longer term.
    Lucas, Softlineck, Shelley and 16 others like this.
  3. DRE

    DRE Well-Known Member

    Thank you Black Jesus! Finally.
  4. CyberAP

    CyberAP Well-Known Member

    Liam W and shenmuee like this.
  5. shenmuee

    shenmuee Active Member

  6. Shelley

    Shelley Well-Known Member

    Oh no. We're going to lose the dc smiley manager.

    I really hope something is done with the smiley manager when you move from tinymce because the current solution is quite frankly a bag of old bollox. No offense but it is.
    Tracy Perry likes this.
  7. Shelley

    Shelley Well-Known Member

    Have you been eyeing up a solution as a possible replacement Mike?
  8. Alfa1

    Alfa1 Well-Known Member

    Great news. Hope to see Redactor replace TMCE.
    Jeremy P likes this.
  9. Reeve of Shinra

    Reeve of Shinra Well-Known Member

    drag and drop image upload sounds sweet!

    edit -- just tried the drag and drop photo and it just rocks... Mike you HAVE to do this! I'll even pay for that license !!!!
    igrec and Shelley like this.
  10. Shelley

    Shelley Well-Known Member

    It does actually look really good that is the first time i've seen this editor.
  11. lostincable

    lostincable Active Member

    Lets not get ahead of ourselves it may not even make it into 1.2 :)

    In the wise words of a master -

    "More waiting is required"
    Liam W and Shelley like this.
  12. igrec

    igrec Member

    And tables wouldn't hart at all
  13. Mike

    Mike XenForo Developer Staff Member

    So this should be sorted for 1.2.

Share This Page