[EAE Add-ons] Node List Mover

[EAE Add-ons] Node List Mover 1.1

No permission to download

Lawrence

Well-known member
Lawrence submitted a new resource:

[EAE-Addons] Node List Mover - Moves the node list below the thread list.

Node list mover gives the admin the option to display the list of nodes below the list of threads. You can set it so all node lists for every forum is listed below the thread lists, or just for select forums. See screen shots.

Phrases:
None.

Template mods:
Two, one to remove the node list above the thread list, and one to add the node list to the bottom of the thread list.

Screen shots:
View attachment 222606View attachment 222607

Read more about this resource...
 

Faust

Well-known member
Hello. I tried this addon, but can't make it work. Selected a forum and still not showing below threads.
 

Lawrence

Well-known member
Hello. I tried this addon, but can't make it work. Selected a forum and still not showing below threads.

Good day, Faust. Thank you for trying the add-on. Have you checked the template modifications to ensure they took for the style you are using? I just installed Node List Mover on my live site after reading your post, and it worked as intended: sub-forums moved

Just a couple of questions as there is really no other things that can cause the nodes to not be moved: have you selected the parent forum for the child nodes you want to move below the thread list? And does the parent allow threads to be posted (if not, you won't be able to tell the child nodes were moved)?
 

Faust

Well-known member
Just a couple of questions as there is really no other things that can cause the nodes to not be moved: have you selected the parent forum for the child nodes you want to move below the thread list? And does the parent allow threads to be posted (if not, you won't be able to tell the child nodes were moved)

On both questions i will answer yes. But i haven't checked the templates.

Where i have to check?
 

Lawrence

Well-known member
AdminCP -> Appearance -> Template modifications. Scroll down until you find the heading: [EAE] Node List Mover. It has two template modifications, both should read: X / 0 / 0. The X should be at least 1 (maybe more depending on the complexity of other styles you may be using). If it reads 1/ 1 / 0, then the template modification failed on one style. If it reads 0 / 0 / 1 then the modification did not take due to an error.
 

Faust

Well-known member
AdminCP -> Appearance -> Template modifications. Scroll down until you find the heading: [EAE] Node List Mover. It has two template modifications, both should read: X / 0 / 0. The X should be at least 1 (maybe more depending on the complexity of other styles you may be using). If it reads 1/ 1 / 0, then the template modification failed on one style. If it reads 0 / 0 / 1 then the modification did not take due to an error.

I have 3/0/0
 

Faust

Well-known member
For both template modifications? If so, it's not that then. Try selecting Move all nodes below thread list in the options for the add-on, does that work?
No changes. Yes, for both templates are the same numbers.
 

Lawrence

Well-known member
Disable the second template modification. Does the list of child nodes disappear (refresh the forum you are viewing with the child nodes you want moved below the threads)? Try it on Xenforo's style, though this should not make a difference as the template modifications all took.
 

Faust

Well-known member
Disable the second template modification. Does the list of child nodes disappear (refresh the forum you are viewing with the child nodes you want moved below the threads)? Try it on Xenforo's style, though this should not make a difference as the template modifications all took.
Maybe i didn't set it up properly. So how i can choose on which nodes to appear subforums? As at the moment i only have chosen which nodes.
 

Lawrence

Well-known member
playground_setting.png

Under the General category, I selected that the forum Playground would have it's child nodes (A Contacts Only Forum, and Thread Count Forum) displayed below the thread list. The image above is how it was done, :), and you can see the result here on my site.
 

Faust

Well-known member
View attachment 251237

Under the General category, I selected that the forum Playground would have it's child nodes (A Contacts Only Forum, and Thread Count Forum) displayed below the thread list. The image above is how it was done, :), and you can see the result here on my site.

This is how is set on my forum. I forgot to mention that i have below thread view widget "similar threads"
 

Lawrence

Well-known member
This is how is set on my forum.

That's good. I take it that the child nodes no longer displays above the list of threads?

I forgot to mention that i have below thread view widget "similar threads"

Is that from an add-on? (I do not have enhanced search) Either way it should not interfere as the template modification that places the child nodes below the thread list uses <xf:ad position="forum_view_below_thread_list" arg-forum="{$forum}" /> in the forum_view template to re-place the list of child nodes below that ad position.

Are the child nodes displaying below the list of similar threads? If not, can you disable the similar threads widget, just to test?
 

Faust

Well-known member
That's good. I take it that the child nodes no longer displays above the list of threads?



Is that from an add-on? (I do not have enhanced search) Either way it should not interfere as the template modification that places the child nodes below the thread list uses <xf:ad position="forum_view_below_thread_list" arg-forum="{$forum}" /> in the forum_view template to re-place the list of child nodes below that ad position.

Are the child nodes displaying below the list of similar threads? If not, can you disable the similar threads widget, just to test?

Is Similar Threads, but not by XF. I'll have to disable it. Would you like to have a look?
 

Lawrence

Well-known member
Top