1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Lack of Interest Disable add-on without having to rebuild

Discussion in 'Closed Suggestions' started by Adam Howard, Oct 1, 2013.

  1. Adam Howard

    Adam Howard Well-Known Member

    I'm in the middle of debugging a possible add-on conflict. This means going though 1 add-on at a time without just adding the special code to config.php

    I'd like to be able to do this without XenForo rebuilding the templates each time. It's becoming a lengthy process because I have to wait for the whole thing to complete.
     
  2. Adam Howard

    Adam Howard Well-Known Member

    Do you have any idea how super annoying this is?
     

    Attached Files:

  3. MattW

    MattW Well-Known Member

    I've never had it rebuild templates just from disabling / enabling addons??
     
  4. Digital Doctor

    Digital Doctor Well-Known Member

    How long does it take for you to rebuild ?
     
  5. Adam Howard

    Adam Howard Well-Known Member

    I have 9 styles and 80+ add-ons ..... So a while
     
  6. Digital Doctor

    Digital Doctor Well-Known Member

    How long is a while ? (Time it).
     
  7. Adam Howard

    Adam Howard Well-Known Member

    It may depend on if the add-on adds TMS entries or not.
     
    Digital Doctor likes this.
  8. Adam Howard

    Adam Howard Well-Known Member

    why ? :cautious:
     
  9. Adam Howard

    Adam Howard Well-Known Member

    To answer your question is it depends on the add-on.

    For example, "quick reply preview" was almost instant. But "[Tinhte] Attach Image Optimization" took a lot longer.
     
  10. MattW

    MattW Well-Known Member

    I have that add-on, and disabling it with 5 styles is instant.
     
    SneakyDave likes this.
  11. Adam Howard

    Adam Howard Well-Known Member

    I could have quoted the wrong add-on.... I have 1 hell of a list I'm weeding though.

    (Add 4 more styles to that list as well)
     
  12. Mike

    Mike XenForo Developer Staff Member

    This is correct. It's also very dependent on server speed (specifically write speed), combined with the number of styles and number of languages (speed * styles * languages). Reducing the number of styles and/or languages will always speed these things up.
     
    DRE and SneakyDave like this.
  13. Adam Howard

    Adam Howard Well-Known Member

    Something for 1.3 ....

    Further optimize the support for more styles and languages. 1.2 is a lot better than 1.1 was, but it can always be better.
     
  14. Mike

    Mike XenForo Developer Staff Member

    The system is optimized for normal usage (which is relatively few of each) and is optimized for display usage. Optimizing for rebuild time (at the detriment of display time) is not a good trade off.
     
  15. tyteen4a03

    tyteen4a03 Well-Known Member

    If you need to quickly test add-on conflicts without the rebuild screen, use Waindigo's Install and Update addon. It will disable rebuild of caches for addon on/off toggle (and install and uninstall), but you will need to remember rebuilding the cache manually by going to the upgrade system after you've finished all operations.
     
  16. DRE

    DRE Well-Known Member

    *uninstalls Spanish and uses Theme Usage Information by @MattW to see which styles are less used*
     
    MattW likes this.
  17. The Forum Heroes

    The Forum Heroes Well-Known Member

    Yeap, if it isn't instant using [Tinhte] Attach Image Optimization then the server is at least 1 of 3 things

    1) very oversold
    2) old or desktop quality CPU
    3) Slow I/O rate.. More then likely the slow I/O is caused by option 1 or 2 also.
     
    MattW likes this.

Share This Page