1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Directory not writable

Discussion in 'XenForo Questions and Support' started by Blacksmith95, Aug 6, 2015.

  1. Blacksmith95

    Blacksmith95 Member

    Hi all,

    I've been having issues with our forums as of late with avatars not uploading and a few other issues. I looked into it and seems to be a permissions issue. So I thought while I'm sorting this out ill also update the forums to the latest 1.4.10.

    Now I have an issue where xenforo thinks that the directories are not 0777 on internal_data and data when they are.

    • The directory /var/www/html/forums/data must be writable. Please change the permissions on this directory to be world writable (chmod 0777). If the directory does not exist, please create it.
    And here are the permissions for the folder.
    4 drwxrwxrwx. 6 admin admin 4096 May 22 19:03 internal_data
    0 drwxrwxrwx. 4 admin admin 55 May 22 22:11 data

    I have tried replacing these folders with brand new copies from xenforo and still no luck.

    Any help would be great!
     
  2. Jake B.

    Jake B. Well-Known Member

    What user does your http user run as?
     
  3. Blacksmith95

    Blacksmith95 Member

  4. Jake B.

    Jake B. Well-Known Member

    Well, http should never run as root. And unless you specifically configured it to then it probably isn't. Try checking your http configuration and seeing what user it runs as and changing the owner of those directories to that user
     
  5. Mike

    Mike XenForo Developer Staff Member

    If you're running something like SELinux, that could be blocking the writes, regardless of what the permissions on those directories are.
     
  6. Blacksmith95

    Blacksmith95 Member

    @Jake B. I checked the configuration of apache in httpd.conf and it is using the user apache and group apache after applying this recursively to the all the files and retsarting httpd service it still did not fix the issue. I have run xenforo for 2 years and this is the first time this has happened!

    @Mike Using centos 7.1
     
  7. Mike

    Mike XenForo Developer Staff Member

    Blacksmith95 likes this.
  8. Jake B.

    Jake B. Well-Known Member

    SELinux isn't an OS, try reading through this: 5.4.2. Disabling SELinux :)
     
  9. Blacksmith95

    Blacksmith95 Member

    @Jake B. @Mike Thanks a lot for the help that solved the issues including a few other issues I had elsewhere on the website I couldnt but my finger on. I thank you for your help! I appreciate it.
     

Share This Page