1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Deleting User Custom Permissions

Discussion in 'Troubleshooting and Problems' started by Ryan Kent, Feb 17, 2011.

  1. Ryan Kent

    Ryan Kent Well-Known Member

    I accidentally gave a User custom permissions. I went into the User customer permissions template and made the necessary corrections to where this user has no special permissions but this user still appears in the Admin CP --> Users --> User Permission area. How can I have this user removed from that area?

    PS. It's actually the admin acct. I wanted to adjust the admin group template and made an error. If it was another acct I'd probably try deleting the acct and making a new one, but don't wish to try this with the admin acct.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Just set all the user permissions to Not Set (no).

    That will remove any custom permissions and they will inherit their permissions from any usergroups they are a member of.
     
  3. Ryan Kent

    Ryan Kent Well-Known Member

    I've done that, but the "admin" still appears in the list. I could ignore it as a minor annoyance. Not sure if this would be considered a bug or a minor request, but since there should be a way to delete an entry in this list.

    Users with Custom Permissions

    1. User Info
      admin
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Make sure you set the fields which accept a value to 0 (Time limit on editing/deleting own posts (minutes), etc.)
     
  5. Ryan Kent

    Ryan Kent Well-Known Member

    All numeric values are 0. The issue arose after I installed XenPorta. The only change I originally made was to ALLOW the two new XenPorta settings. When I discovered my error, I changed the settings back to Not Set (NO).
     
  6. Mike

    Mike XenForo Developer Staff Member

    Note that moderators are expected to show up there. That's how moderator permissions work.
     
  7. Ryan Kent

    Ryan Kent Well-Known Member

    This is a new forum setup and there are presently no admins or mods. I went ahead and gave moderator rights to a test account and it does not show up here. I then gave admin rights to that same account and it still does not show up here.

    I realize there are a lot more serious concerns, and this issue is minor. You may just want to make a note of it in case it is brought up later.
     
    anotheralias likes this.
  8. anotheralias

    anotheralias Well-Known Member

    I have the same problem. I gave someone user-specific permissions, it was only intended to be temporary; now I can't delete their name out of that section - I can only change the permissions. Which is annoying.
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    I've just tested this on my local install and was able to remove all users with custom permissions, moderators, administrators and super admins.

    I'll do some more testing to see if I can find out when it doesn't work.
     
  10. Ryan Kent

    Ryan Kent Well-Known Member

    Attached are screenshots of what I am looking at in case you can see something I am missing.

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
     
  11. Brogan

    Brogan XenForo Moderator Staff Member

    Three screenshots show all green for general moderator permissions, forum moderator permissions and profile post moderator permissions.

    You haven't set everything to Not Set (No) as I suggested.
     
    anotheralias and Oracle like this.
  12. Ryan Kent

    Ryan Kent Well-Known Member

    I changed all the permissions to Not Set (NO) based on your last post and.....the admin account was removed from the Custom Permissions list!

    Thanks so much Brogan! You are awesome! I can't begin to say how much I appreciate how you stick with an issue until it is resolved.

    As a side note, no one else has access to the admin account except for myself, and no one else has any permissions on these forums higher then Registered User. I never accessed the User Permission screen before today, I was only on there for moments, and the sole purpose was to change the XenPorta settings. I definitely did not change those settings to Allow, so I left them as I found them. I suspect the system somehow assigned those values there causing the problem.

    anotheralias, I hope this information helps you. Change all values to Not Set (NO) and the issue should be resolved.
     
    anotheralias likes this.
  13. anotheralias

    anotheralias Well-Known Member

    Thanks Brogan and Oracle - I'll give that a try. :)
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    As an aside, Mike has also tweaked the code slightly to do with custom permissions for deleted add-ons so hopefully there should be no issues going forward.
     

Share This Page