1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Database Trouble?

Discussion in 'Troubleshooting and Problems' started by ElijahGreen, Jul 24, 2015.

Tags:
  1. ElijahGreen

    ElijahGreen New Member

    I'm kind of useless when coming with databases and website development so I have no sort of knowledge with this type of stuff.

    Basically, I accidentally wiped out my Xenforo database and my site seems to have trouble connecting to it now. The database has no tables now and the software refuses to connect to it. All credentials for the MySql information is correct.

    I am NOT worried about the lost data and definitely not trying to recover it. I just want my site to connect to the database.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    If the database is empty then you will need to restore it or reinstall XenForo.
     
  3. ElijahGreen

    ElijahGreen New Member

    I'm getting this error when trying to reinstall now.


    Code:
    Server Error
    
    mkdir(): Permission denied
    
    XenForo_Application::handlePhpError()
    mkdir() in XenForo/Helper/File.php at line 72
    XenForo_Helper_File::createDirectory() in XenForo/Install/Model/Install.php at line 291
    XenForo_Install_Model_Install->createDirectories() in XenForo/Install/Controller/Install.php at line 220
    XenForo_Install_Controller_Install->actionStep2() in XenForo/FrontController.php at line 347
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /var/www/html/install/index.php at line 18
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    That's a server configuration issue related to file and folder permissions.

    You appear to have done a little more than wipe the database - have you also been messing around with the file server, etc?
     
  5. ElijahGreen

    ElijahGreen New Member

    Yeah. I've been trying to reinstall the software. I didn't do the initial install of the software when I first purchased the license so I figured I would just delete it and reupload it.
     

Share This Page