• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Custom Contact URL in a New Tab Instead of in a Same Tab

Shyuan

Well-known member
#1
Hi,

I put Custom URL for my Contact URL. However, I would like it to popup a new tab instead of opening the custom URL in the same tab. May I know how can I do that? Thanks. :)
 

Jeremy

Well-known member
#2
Change the contact us link in the footer template to remove the OverlayTrigger class and add the following into the a element:
HTML:
target="_blank"
 

Shyuan

Well-known member
#6
Hi @King Kovifor, just a question. Do I actually remove the whole thing below or just the class="OverlayTrigger"?

Code:
'class="OverlayTrigger" data-overlayOptions="{"fixed":false}"'
Your advise would be much appreciated. Thanks :)
 

Shyuan

Well-known member
#7
Sorry, but could you please highlight the exact code that I have to remove from this line? I see three "overlay" word in that line, not sure if they are all related and needed to be removed since class="OverlayTrigger" is to be removed.

Code:
<li class="contactLink"><a href="{$xenOptions.contactUrl.custom}" {xen:if {$xenOptions.contactUrl.overlay}, 'class="OverlayTrigger" data-overlayOptions="{&quot;fixed&quot;:false}"'} target="_blank">{xen:phrase contact_us}</a></li>
 

Jeremy

Well-known member
#8
Are you using a custom contact URL? If so, it appears there's an option to open it in an overlay or not. Just uncheck it here:
ACP -> Options -> Basic Board Information -> "Open this link in an overlay"

Or remove this code in red:

Code:
<li class="contactLink"><a href="{$xenOptions.contactUrl.custom}" {xen:if {$xenOptions.contactUrl.overlay}, 'class="OverlayTrigger" data-overlayOptions="{&quot;fixed&quot;:false}"'} target="_blank">{xen:phrase contact_us}</a></li>
 

Shyuan

Well-known member
#9
Alright, I got you, either way will work. But since there's the option, I will choose to untick it. I have actually disabled that option in my admin panel. I just added the target="_blank" and it's working fine. Thank you so much :)