• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Cron Problems

topcat

Well-known member
#1
Recently noticed that my latest member stats weren't updating. so looked at my cron entries and 90% of them are set to next run 16th Dec 2013. some of the are earlier in august etc.

what is the problem. what has caused this and how do i rectify it?
 

Mike

XenForo developer
Staff member
#2
Ones in August sound like disabled add-ons, but you should upgrade to 1.2.4. There are changes to help prevent this.
 

topcat

Well-known member
#4
ok updated, this as sorted the default xenforo crons, but the ones for mods i am using are still fecked.

xfsoccer willl next run in december 1970 wtf

lots of others are still dec 16 2013

what on earth has caused this, Do I need to re install all the effected mods to repair the crons?
 

Mike

XenForo developer
Staff member
#5
Well I couldn't speak to the add-on per se -- if the add-on is disabled, crons won't run.

If updating doesn't resolve it, then there's something more fundamental at play. I would disable all add-ons and ensure that all files path the file health check.
 

topcat

Well-known member
#6
all cron entries seem to be ok now,

ran the health check and all files are there.

only problem now since the update when members click on newposts /whats new etc

they get this

Server Error
Undefined index: node_name

  1. XenForo_Application::handlePhpError() in XenForo/ControllerPublic/FindNew.php at line 77
  2. XenForo_ControllerPublic_FindNew->actionPosts() in XenForo/FrontController.php at line 347
  3. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  4. XenForo_FrontController->run() in /home/xxxxxxx/public_html/v2/index.php at line 13

and i have a bout 10 pages of the same error in my log from members clicking the link

Undefined index: node_name 3 minutes ago - library/XenForo/ControllerPublic/FindNew.php:77
 
Last edited: