• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 cron entries not happening.

JMEWLS

Active member
#2
my page container:

Code:
<!DOCTYPE html>
<html id="XenForo" lang="{$visitorLanguage.language_code}" dir="{$visitorLanguage.text_direction}" class="Public {xen:if {$visitor.user_id}, 'LoggedIn', 'LoggedOut'} {xen:if {$sidebar}, 'Sidebar', 'NoSidebar'}" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<xen:hook name="page_container_head">
   <meta charset="utf-8" />
   <xen:if is="{$requestPaths.fullBasePath}">
     <base href="{$requestPaths.fullBasePath}" />
     <script><xen:comment>/* Chrome bug and for Google cache */</xen:comment>
       var _b = document.getElementsByTagName('base')[0], _bH = "{xen:jsescape $requestPaths.fullBasePath}";
       if (_b && _b.href != _bH) _b.href = _bH;
     </script>
   </xen:if>

   <title><xen:if is="{$title}">{xen:raw $title} | {$xenOptions.boardTitle}<xen:else />{$xenOptions.boardTitle}</xen:if></title>
   
   <noscript><style>.JsOnly { display: none !important; }</style></noscript>
   <link rel="stylesheet" href="css.php?css=xenforo,form,public&amp;style={xen:urlencode $_styleId}&amp;dir={$visitorLanguage.text_direction}&amp;d={$visitorStyle.last_modified_date}" />
   <!--XenForo_Require:CSS-->   
   {xen:helper ignoredCss, {$visitor.ignoredUsers}}

   <xen:include template="google_analytics" />
   <xen:include template="page_container_js_head" />
   
   <link rel="alternate" type="application/rss+xml" title="{xen:phrase rss_feed_for_x, 'title={$xenOptions.boardTitle}'}" href="{xen:link forums/-/index.rss}" />
   <xen:if is="{$pageDescription.content} AND !{$pageDescription.skipmeta} AND !{$head.description}"><meta name="description" content="{xen:string wordTrim, {xen:helper stripHtml, {xen:raw $pageDescription.content}}, 200}" /></xen:if>
   <xen:if is="{$head}"><xen:foreach loop="$head" value="$headElement">{xen:raw $headElement}</xen:foreach></xen:if>
</xen:hook>
</head>

<body{xen:if {$bodyClasses}, ' class="{$bodyClasses}"'}>
<xen:hook name="body">

<xen:if is="{$visitor.is_moderator} || {$visitor.is_admin}">
   <xen:include template="moderator_bar" />
<xen:elseif is="!{$visitor.user_id} && !{$hideLoginBar}" />
   <xen:include template="login_bar" />
</xen:if>

<div id="headerMover">

   <div id="headerProxy"></div>

<div id="content" class="{$contentTemplate}">
   <div class="pageWidth">

     <div class="pageContent">
       <!-- main content area -->
       
       <xen:hook name="page_container_content_top" />
<xen:include template="ad_above_top_breadcrumb" />
             
             <xen:hook name="page_container_breadcrumb_top">
             <div class="breadBoxTop">
               <xen:if is="{$topctrl}"><div class="topCtrl">{xen:raw $topctrl}</div></xen:if>
               <xen:include template="breadcrumb"><xen:set var="$microdata">1</xen:set></xen:include>
             </div>
             </xen:hook>
             
             <xen:include template="ad_below_top_breadcrumb" />
       
       <xen:if is="{$sidebar}">
         <div class="mainContainer">
           <div class="mainContent"></xen:if>
             
             
           
             <xen:hook name="page_container_notices">
             <xen:include template="notices" />             
             </xen:hook>
             
             <xen:hook name="page_container_content_title_bar">
             <xen:if is="!{$noH1}">             
               <!-- h1 title, description -->
               <div class="titleBar">
                 {xen:raw $beforeH1}
                 <h1><xen:if
                   is="{$h1}">{xen:raw $h1}<xen:elseif
                   is="{$title}" />{xen:raw $title}<xen:else
                   />{$xenOptions.boardTitle}</xen:if></h1>
                 
                 <xen:if is="{$pageDescription.content}"><p id="pageDescription" class="muted {$pageDescription.class}">{xen:raw $pageDescription.content}</p></xen:if>
               </div>
             </xen:if>
             </xen:hook>
             
             <xen:include template="ad_above_content" />
             
             <!-- main template -->
             {xen:raw $contents}
             
             <xen:include template="ad_below_content" />
             
             <xen:if is="!{$visitor.user_id} && !{$hideLoginBar}">
               <!-- login form, to be moved to the upper drop-down -->
               <xen:include template="login_bar_form" />
             </xen:if>
             
           <xen:if is="{$sidebar}"></div>
         </div>
         
         <!-- sidebar -->
         <aside>
           <div class="sidebar">
             <xen:hook name="page_container_sidebar">
             <xen:include template="ad_sidebar_top" />
             <xen:if is="!{$noVisitorPanel}"><xen:include template="sidebar_visitor_panel" /></xen:if>
             {xen:raw $sidebar}
             <xen:include template="ad_sidebar_bottom" />
             </xen:hook>
           </div>
         </aside>
       </xen:if>
       
       <xen:hook name="page_container_breadcrumb_bottom">       
       <div class="breadBoxBottom"><xen:include template="breadcrumb" /></div>
       </xen:hook>
             
       <xen:include template="ad_below_bottom_breadcrumb" />
             
     </div>
   </div>
</div>

<header>
   <xen:include template="header" />
   <xen:edithint template="navigation" />
   <xen:edithint template="search_bar" />
</header>

</div>

<footer>
   <xen:include template="footer" />
</footer>

<xen:include template="page_container_js_body" />

<xen:if is="{$cronLink}"><img src="{$cronLink}" width="1" height="1" alt="" style="display: none" /></xen:if>

</xen:hook>
</body>
</html>
 

Mike

XenForo developer
Staff member
#3
Your PAGE_CONTAINER template is out of date. I'd recommend reverting it (and redoing your changes) or potentially using the merge system if you haven't.
 

Mike

XenForo developer
Staff member
#8
If @King Kovifor's suggestion worked, but it has since broken, then it's likely that one of your add-ons has a cron task that's failing. I could only recommend disabling add-ons.

There is a fix in for 1.2.1 that prevents the issue from fundamentally occurring (prevents the crons from totally stopping), though a cron having a fatal error is a fairly big deal and should be resolved.
 

Mike Fara

Active member
#9
If @King Kovifor's suggestion worked, but it has since broken, then it's likely that one of your add-ons has a cron task that's failing. I could only recommend disabling add-ons.

There is a fix in for 1.2.1 that prevents the issue from fundamentally occurring (prevents the crons from totally stopping), though a cron having a fatal error is a fairly big deal and should be resolved.
This as well as the post above from @King Kovifor were incredibly helpful, so far, in resolving the same difficulty. I am running multiple sitemap add-ons in cron, and this may have something to do with it. Worst case scenario is that these can be disabled and run manually, until such a flaw is found. Hopefully it will not stall again, but thanks a lot for the info on this issue. Unfortunately, I made a duplicate thread and support request addendum that could be dismissed or removed at this time.
 

Mike

XenForo developer
Staff member
#10
Well, the issue is that I already applied the fix to your board when I was dealing with the bulk threads issue as your cron tasks were stopped then.

But yes, that is a workaround. I will continue research for 1.2.1.