1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 cPanel transfer made XenForo go wrong

Discussion in 'Troubleshooting and Problems' started by Daniel Bittar, Oct 2, 2013.

  1. Daniel Bittar

    Daniel Bittar Member

    Hi there!

    Well, I was changing providers and did a simple cPanel transfer in a working XenForo install. Now everything is broken. It is so broken I can't even describe. You can see it here: http://forum.cirandaespirita.com.br

    How can I fix this?

    Thanks a lot,
    Daniel Bittar.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Looks like the transfer failed in several areas.

    A major problem is the missing xf_user table.

    You will need to restore a complete database backup and then do a file health check to ensure all files were copied OK.
  3. AndyB

    AndyB Well-Known Member

  4. Liam W

    Liam W Well-Known Member

    Is the database username/database name the same to begin with? Normally cpanel names it based on the cPanel username, which will probably have changed.

    Obviously, that's just one issue.
  5. Brogan

    Brogan XenForo Moderator Staff Member

    The FAQ explains how to do a move.

    How can I move my installation to a different domain or host?
    Backup the existing database and server files. Copy them to the new domain/server and update the library/config.php file with the new database details as required. It may be necessary to set permissions for the data and internal_data directories to world writeable (CHMOD 0777). Lastly, update the Board URL in the ACP -> Options -> Basic Board Information, if it has changed.
    Note that if you are moving to a different type of web server and have Friendly URLs enabled, you will need to make the appropriate changes. Refer to the Friendly URLs section of the XenForo Manual for more details.

  6. Daniel Bittar

    Daniel Bittar Member

    Hi Brogan!

    I'm not really sure why but the database transfer had failed. Now I fixed it but my styles aren't loading. Could you take a look at it, please?

    Thanks again,
    Daniel Bittar.
  7. Liam W

    Liam W Well-Known Member

    Template compilation results in error:


  8. Brogan

    Brogan XenForo Moderator Staff Member

    This is what I see when I click on the XenForo CSS in the page source: http://forum.cirandaespirita.com.br/css.php?css=xenforo,form,public&style=2&dir=LTR&d=1368842241

    An exception occurred: preg_match(): Compilation failed: unknown option bit(s) set at offset 0 in /home/cirandae/public_html/forum/library/XenForo/CssOutput.php on line 90
    preg_match() in XenForo/CssOutput.php at line 90
    XenForo_CssOutput->parseInput() in XenForo/CssOutput.php at line 73
    XenForo_CssOutput->__construct() in XenForo/CssOutput.php at line 588
    XenForo_CssOutput::run() in /home/cirandae/public_html/forum/css.php at line 12
  9. xmlxp

    xmlxp Active Member

    That sounds like server apache/php version incompatibility with xenforo
  10. Liam W

    Liam W Well-Known Member

    What PHP version is the server running?

    xenForo needs PHP 5.2 minimum.
  11. Daniel Bittar

    Daniel Bittar Member

  12. xmlxp

    xmlxp Active Member

    php 5.4.x is not compatible with xf1.1, you should downgrade to php 5.3.27
  13. Liam W

    Liam W Well-Known Member

    Wrong, where did you read that?
  14. xmlxp

    xmlxp Active Member

    I run xf1.1.1 and when I upgrade to php5.4 I get the same error so I stay on php5.3.27 and Apache 2.2.25 for now
  15. The Forum Heroes

    The Forum Heroes Well-Known Member

    Delete the account on the new server. Increase your max_limit and try again MySQL timed out taking to long to transfer via WHM
  16. Daniel Bittar

    Daniel Bittar Member

    Hi Mike!

    Which max_limit should I increase?

    Thanks again,
    Daniel Bittar.
  17. The Forum Heroes

    The Forum Heroes Well-Known Member

    Your timeout limits.
  18. Mike

    Mike XenForo Developer Staff Member

    For reference, this error indicates that somehow, you have PCRE without Unicode support. This basically has to be explicitly disabled. Usually you want to just compile PCRE from the bundled version that comes with PHP. If it's a managed server, your host may be able to help.
    Adam Howard and Brogan like this.
  19. Daniel Bittar

    Daniel Bittar Member

    Well, as strange as it seems I can confirm it doesn't work with PHP 5.3.x but it works with PHP 5.3.x or 5.5.x.

Share This Page