• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Copy and Paste images

Joeychgo

Well-known member
#1
I've noticed that sometimes I can copy and paste images into a post, other times I cannot.

Can someone explain this to me please?
 

Chris D

XenForo developer
Staff member
#2
Have you got a specific example of what you are copying and pasting from? Or is a bit random? Which browser and OS? Is it a problem just on your own site or here too?
 

Mr Lucky

Well-known member
#8
I read this as copy and paste from a computer desktop, which I didn't know was possible. However dragging and dropping from a desktop is no problem, as mentioned.
 

0ptima

Well-known member
#10
As my previous post was not exactly obvious that it was an image, I tried pasting it again after adding some visual effects to it. I pasted it and then got the following.

upload_2015-8-16_13-47-58.png

Funny thing is, the image in this post was pasted from the clipboard.
 

Mike

XenForo developer
Staff member
#13
There are browser differences as to what specifically is available in terms of pasting files from the clipboard. There are a couple of different representations of an image and I believe Chrome only supports one (the image data in the clipboard, not the file reference).
 

Mike

XenForo developer
Staff member
#15
The short answer is browser limitations and how the image is actually stored in your computer's clipboard. There's really not anything that you (or we) can do about it, as far as I know.