1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Contact Form Reply Address

Discussion in 'XenForo Questions and Support' started by System0, Jan 17, 2015.

  1. System0

    System0 Active Member

    I have noticed that whenever someone contacts me through my forum, the reply email address defaults to my own email address instead of the email address of the person who sent me the email.

    Is there any way to change this so that I do not need to manually change the reply email address every time I respond to an email?

    Thanks,
    Kevin
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Have you edited the templates at all?

    What do the email headers look like?
     
  3. System0

    System0 Active Member

    No I have not edited any templates.

    I have sent the email header to you on a text file via a private message.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    It all looks fine to me - I can see the 'Reply-To' field is the actual sender's name and email address.

    Which email application are you using to reply to the email?
     
  5. System0

    System0 Active Member

    I am using Gmail.
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Can you screenshot the email as it appears in Gmail?
    You can attach it to the same conversation.
     
  7. System0

    System0 Active Member

    I sent you three screenshots. Thanks :)
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    Curious.

    The reply to address is clearly there, and Gmail displays it, but then uses the delivered to address.

    Do you have access to another email client, such as Outlook?

    I am unable to replicate the issue - it all works fine for me in both Gmail on the web and Outlook.
     
  9. Mike

    Mike XenForo Developer Staff Member

    You're running into a Gmail issue and the specific reason the "Sender info in From header on contact emails" option was created after changing the system in 1.4. You'll need to enable the option.

    (It happens because the From address is your Gmail account's address so it thinks you sent the message so it ignores the reply to.)
     
    Brogan likes this.
  10. System0

    System0 Active Member

    Thanks for all your help with this.

    I can confirm this is a Gmail issue. I changed my forum contact email to my hotmail account and when I responded via hotmail, the correct email address was used.

    I then switched back to the email address I use Gmail and selected "Sender info in From header on contact emails"; however, the problem with the reply to email address remains.

    Any idea if there is a way to resolve this. I use Gmail to handle all my business emails. Therefore, I am not keen on changing email clients.
     
  11. Mike

    Mike XenForo Developer Staff Member

    With that option enabled, there's no Reply-To header and the from is the email of the user sending it. If you're seeing a Reply-To, I'd check that you're looking at an email sent after the option was enabled.
     
  12. System0

    System0 Active Member

    I just checked again. Even if the option is enabled, the reply address defaults to my own email address.
     
  13. Mike

    Mike XenForo Developer Staff Member

    Can you show me the headers of the message? (The original headers -- you'll have to view the raw message.)
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    I'll add you to the conversation Mike.
     
  15. System0

    System0 Active Member

    Messaged :)
     

Share This Page