• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Confirmation joining not working correctly.

WCFA

Active member
#1
I have in ACP, the registration set to:
Registration set up to Enable Email Confirmation,
since opening it has been on manual.
I opened a test account:
1. registration worked and sent me a confirmation email.
2. clicking the confirmation link went to the website and did not do anything just went to the main page still
said I was not a member and was waiting for confirmation.

There are no errors in the logs, by all accounts the link should work.
I tried copy pasting the code into other browsers IE, Firefox, Chrome and no luck.

Board url, in ACP looks to be correct.
XF is in the root and the url shows
http://www.westcoastfirearms.org/account-confirmation/460/email?c=9090aebb6c2e5bc6
Which all looks correct.

And is the same in the board info, no forum extension or index.php like I have read other did.
Mine seems right. but is not working.

I know emails are working as it sends it wonder whats up.

Puzzled .

Thank You.
 
Last edited:

Mike

XenForo developer
Staff member
#2
By default, the only time that page redirects is when there's no confirmation record found for that user at all -- likely because they already confirmed.

First, I would disable all add-ons and then try registering a new user. The URL looks correct so there shouldn't be anything interfering.
 

WCFA

Active member
#3
That the odd thing is it was a test account and showed unconfirmed . Which makes no really . Its showing a page at confirmed,
yet it is not. I can manually approve members, members get an approval and all is right in the XF world.
However this one aspect is illusive. I Disabled the add-on and still now luck. No Mysql error either.
The site is running flawlessly, no error in the logs nothing to indicate any issue. However the confirmation goes to the
the forum and does nothing.
 

WCFA

Active member
#6
Ok now thats weird now its working :). Maybe the addons were not set off quite when I tested it cause it just worked for me too.
Cool thanks Mike, didnt even thing to try addons. now that will be easy enough to find the culprit.
Darn ole Add-on causing havoc in my forum hehe.
Have a good one, gees was driving me nuts, and I guess thats when I should have looked at the small possibilities.

Thank You
 

ALMUSA

Active member
#7
It looks like I'm having the same issue here.

Email conformation is enabled, send conformation link to email after registration but once you click on the link it directs to an error page saying that the requested page couldn't be found!

Here is a screenshot.



Any idea how to fix this?
 

Mike

XenForo developer
Staff member
#10
This is almost certainly down to your "Board URL" setting being incorrect. It needs to be the URL to where you installed XenForo.
 

ALMUSA

Active member
#11
This is almost certainly down to your "Board URL" setting being incorrect. It needs to be the URL to where you installed XenForo.
Forgive my ignorance but I'm no expert in this.

The URL http://www.example.com/forum is not working, you get directed to an error page. Now I have removed /forum from the URL and it worked.

It is actually /forumS with an S. I added an S and it worked.

Now when you click on Forums it brings you back to www.example.com which is the Home page.

Home and forum are same URL!

Xenforo installed inside /public_html. Should I move it to somewhere else?
 

Mike

XenForo developer
Staff member
#12
The board URL is the URL (just to the directory) that you installed XenForo itself into. If you installed into public_html, you installed it into the root so example.com is the correct value.
 

ALMUSA

Active member
#13
The board URL is the URL (just to the directory) that you installed XenForo itself into. If you installed into public_html, you installed it into the root so example.com is the correct value.
Thanks Mike.

But how come the home page and forums are both same URL. When you click on ''Forums'' and you click ''Home'' the URL stays the same. Sorry for going off topic here.