1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Cant upload large files.

Discussion in 'Troubleshooting and Problems' started by Skyuser, Jan 19, 2014.

  1. Skyuser

    Skyuser Member

    Hello. I have a problem with uploading large files.
    Permissions in xenforo admin set to 100M
    In php.ini upload_max_filesize = 100M;
    post_max_size = 150M;
    Memory_limit = 256M;
    data and internal_data chmod set to 777;

    Still can not upload files larger than 12 M-15M; Always the same error;
  2. Chris D

    Chris D XenForo Developer Staff Member

    What is the error?
  3. Skyuser

    Skyuser Member

    Like this
  4. RoldanLT

    RoldanLT Well-Known Member

    I think your using nginx.
    In your domain.conf or nginx.conf
    Check this value = client_max_body_size

    Should be higher than your limit set on xenforo.
    Chris D likes this.
  5. Skyuser

    Skyuser Member

    Made client_max_body_size 120M;
    Nothing changed.
  6. Skyuser

    Skyuser Member

    + I need help with permissions in folder internal_data. All files was set to 777. Trying to set everything back, but i dont remember what was the standart permissions.
  7. RoldanLT

    RoldanLT Well-Known Member

    Restart nginx/php-fpm after saving the .conf file.
  8. RoldanLT

    RoldanLT Well-Known Member

    775 for folder and 644 for files.
    That's the standard.
  9. Chris D

    Chris D XenForo Developer Staff Member

    777 is the correct values for internal_data and data AND the files within.

    See step 3: http://xenforo.com/help/installation/

  10. RoldanLT

    RoldanLT Well-Known Member

    775 works fine for me, though it depends on the server :)
  11. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That is the non-specific upload error message. But if it happens only on large files then it must be a server limit of some kind.

    Here are some server settings that may be limiting:


  12. Skyuser

    Skyuser Member

    max_execution_time = 300
    memory_limit = 256M
    post_max_size = 150M
    upload_max_filesize = 100M
    Not working.

    Why i need to change mysql parameters?
  13. Skyuser

    Skyuser Member

    .rar files dont want to start even uploading - instant error message :oops:
  14. RoldanLT

    RoldanLT Well-Known Member

    This is the closest fix I can think.
  15. Steve F

    Steve F Well-Known Member

    Usually if it is related to a file extension you will receive a error for that, can you upload a normal .zip file the same size? Do you have 'rar' in the allowed list in the ACP?
  16. Skyuser

    Skyuser Member

    Yes i have.
    I can upload 12Mb .rar file but with 30+ MB appears error message as shown higher.

    Edited my.cnf file
    max_allowed_packet = 110M

    Restarted every service and still this doesnt want to work.

    Edited nginx.conf
    client_max_body_size = 110M between http { }, restated nginx and no. Still error message
  17. Skyuser

    Skyuser Member

    I have apache/nginx as front/back-end.
    Anyone can post your configuration of php.ini, my.cnf, nginx.conf with working 50M+ upload?
    I have no ideas what to do

Share This Page