1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Cant upload files

Discussion in 'Troubleshooting and Problems' started by combatgamez, Sep 6, 2015.

  1. combatgamez

    combatgamez New Member

    When I try to upload files for some reason it has stopped working and I have no idea why.

    I attach the file as per normal and it says uploading and gets to 100%, then nothing happens.

    I can then complete the post and there is no attachment.

    Screen shot below, same for creating a new topic or replying.

  2. Amaury

    Amaury Well-Known Member

    Are there any errors in the ACP error log?
  3. Martok

    Martok Well-Known Member

    Also check that the data and internal_data directories are recursively set to world writeable (CHMOD 0777).
  4. combatgamez

    combatgamez New Member

    No errors in ACP, weird thing is I could upload pics fine a few days ago but now nothing.

    Thanks Martok, I will check and advise.
  5. combatgamez

    combatgamez New Member

    yes those 2 directories are 777

    755 for directories inside those.

    Any other suggestions anyone?
  6. Martok

    Martok Well-Known Member

    Try each of the following:

    • Try another browser
    • Try another device
    • Disable the Flash uploader in your account preferences
    • Try with all add-ons disabled and using an unedited default style
    See if you have any success with any of these.
  7. combatgamez

    combatgamez New Member

    Ok in Chrome is gives me a error message as per below.


    However I have disabled the flash upload and now it is uploading ok?

    So does anyone know why this may happen? As it was ok a few days ago... weird indeed?

    Maybe my host has done something to my account, because when I was having issues I tried to upload multiple files and my host banned my IP (again) apparently. Which doesnt seem to make sense to me.. anyway..
  8. Mike

    Mike XenForo Developer Staff Member

    It's very possible that there are mod_security rules that are being triggered; we have seen that before. Alternatively, if your forum is behind password protection (via .htaccess), Flash has issues with that so it likely won't work.
  9. ProCom

    ProCom Active Member

    **** FIXED *****

    I recently moved hosting companies from one VPS to Linode. After the move everything was working fine, but I started having members complaining that some images were not uploading properly.

    They would upload an attachment (image) and the progress bar would hit 100% and then nothing would happen.

    After a bunch of researching, I changed the following settings for PHP and MySQL to match my previous VPS. I'm unfortunately not sure which one was successful in fixing the problem, but wanted to post here (and a few other related threads) to share that this worked for me!

    pico /usr/local/lib/php.ini
    memory_limit = from 32M to 158M

    pico /etc/my.cnf
    max_allowed_packet=268435456 to max_allowed_packet=64M
    wait_timeout=10 to 45

    (make sure to restart your services after you make the changes)

Share This Page