1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't install Xenforo on my VDS

Discussion in 'Installation, Upgrade, and Import Support' started by SeVeN, Oct 6, 2010.

  1. SeVeN

    SeVeN Active Member

    Hi, i try to install the Forum but it don't work :(

    Error:
    Code:
    Server Error
    
    is_readable() [<a href='function.is-readable'>function.is-readable</a>]: open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/var/www/username/data:.)
    XenForo_Application::handlePhpError()
    is_readable() in /var/www/username/data/usr/sites/dft-x/library/Zend/Cache/Backend.php at line 208
    Zend_Cache_Backend->_isGoodTmpDir() in /var/www/username/data/usr/sites/dft-x/library/Zend/Cache/Backend.php at line 178
    Zend_Cache_Backend->getTmpDir() in /var/www/username/data/usr/sites/dft-x/library/Zend/Cache/Backend/File.php at line 123
    Zend_Cache_Backend_File->__construct() in /var/www/username/data/usr/sites/dft-x/library/Zend/Cache.php at line 153
    Zend_Cache::_makeBackend() in /var/www/username/data/usr/sites/dft-x/library/Zend/Cache.php at line 94
    Zend_Cache::factory() in /var/www/username/data/usr/sites/dft-x/library/XenForo/Application.php at line 513
    XenForo_Application->loadCache()
    call_user_func_array() in /var/www/username/data/usr/sites/dft-x/library/XenForo/Application.php at line 706
    XenForo_Application->lazyLoad() in /var/www/username/data/usr/sites/dft-x/library/XenForo/Application.php at line 736
    XenForo_Application::get() in /var/www/username/data/usr/sites/dft-x/library/XenForo/Model.php at line 146
    XenForo_Model->_getCache() in /var/www/username/data/usr/sites/dft-x/library/XenForo/Model/DataRegistry.php at line 158
    XenForo_Model_DataRegistry->set() in /var/www/username/data/usr/sites/dft-x/library/XenForo/Model/Cron.php at line 393
    XenForo_Model_Cron->updateMinimumNextRunTime() in /var/www/username/data/usr/sites/dft-x/library/XenForo/Model/Cron.php at line 568
    XenForo_Model_Cron->importCronEntriesAddOnXml() in /var/www/username/data/usr/sites/dft-x/library/XenForo/Model/Cron.php at line 504
    XenForo_Model_Cron->importCronDevelopmentXml() in /var/www/username/data/usr/sites/dft-x/library/XenForo/CacheRebuilder/ImportMasterData.php at line 35
    XenForo_CacheRebuilder_ImportMasterData->rebuild() in /var/www/username/data/usr/sites/dft-x/library/XenForo/ControllerHelper/CacheRebuild.php at line 26
    XenForo_ControllerHelper_CacheRebuild->rebuildCache() in /var/www/username/data/usr/sites/dft-x/library/XenForo/Install/Controller/Install.php at line 243
    XenForo_Install_Controller_Install->actionStep2b() in /var/www/username/data/usr/sites/dft-x/library/XenForo/FrontController.php at line 303
    XenForo_FrontController->dispatch() in /var/www/username/data/usr/sites/dft-x/library/XenForo/FrontController.php at line 132
    XenForo_FrontController->run() in /var/www/username/data/usr/sites/dft-x/install/index.php at line 17 
    How can i install the forum???

    Thanks
     

    Attached Files:

  2. brendanc

    brendanc Active Member

    You mention VDS... I am assuming this is Virtual Dedicated Server. You should have access to php.ini

    Looks like your PHP Safe Mode is on.

    Edit your php.ini and find

    Code:
    safe_mode = on
    Replace with:

    Code:
    safe_mode = off
     
    SeVeN likes this.
  3. brendanc

    brendanc Active Member

  4. SeVeN

    SeVeN Active Member

    1. PHP requirements are satisfied.
    2. Safe Mode is turned off.
    These requirements have been met prior to installation :(
     
  5. Please check your open_basedir settings (possibly adding /tmp to it), this might also work as the same issue has shown up in wordpress from time to time on certain installations.
     
  6. SeVeN

    SeVeN Active Member

    Problem solved!

    Solution:
    1. Added a line in Virtual host (httpd.conf):
      Code:
      php_admin_value open_basedir "/var/www/username/data:/tmp/"
    2. Edited a line in Cach Settings (<xenForo>\library\Zend\Cache\Backend\File.php)
      Code:
      'cache_dir' => null,
      to
      Code:
      'cache_dir' => '/var/www/sevenos/data/usr/sites/dft-x/temp',
    All thanks! ;)
     
  7. Mike

    Mike XenForo Developer Staff Member

    This is fixed for beta 2 as well, BTW.
     
    Daracon and SeVeN like this.

Share This Page