XF 2.0 Can't install XenForo anymore?

Jake B.

Well-known member
#1
When trying to install XF 2.0.6 Beta 2 I get this error:

jakebooher:~/Sites/xf2 (master) $ php cmd.php xf:install -v


[XF\Db\Exception]
No such file or directory


Exception trace:
() at /Users/jakebooher/Sites/xf2/src/XF/Db/Mysqli/Adapter.php:160
XF\Db\Mysqli\Adapter->makeConnection() at /Users/jakebooher/Sites/xf2/src/XF/Db/Mysqli/Adapter.php:28
XF\Db\Mysqli\Adapter->getConnection() at /Users/jakebooher/Sites/xf2/src/XF/Db/AbstractAdapter.php:51
XF\Db\AbstractAdapter->connect() at /Users/jakebooher/Sites/xf2/src/XF/Db/Mysqli/Adapter.php:84
XF\Db\Mysqli\Adapter->getServerVersion() at /Users/jakebooher/Sites/xf2/src/XF/Install/Helper.php:127
XF\Install\Helper->getRequirementErrors() at /Users/jakebooher/Sites/xf2/src/XF/Cli/Command/Install.php:100
XF\Cli\Command\Install->execute() at /Users/jakebooher/Sites/xf2/src/vendor/symfony/console/Command/Command.php:242
Symfony\Component\Console\Command\Command->run() at /Users/jakebooher/Sites/xf2/src/vendor/symfony/console/Application.php:843
Symfony\Component\Console\Application->doRunCommand() at /Users/jakebooher/Sites/xf2/src/vendor/symfony/console/Application.php:193
Symfony\Component\Console\Application->doRun() at /Users/jakebooher/Sites/xf2/src/vendor/symfony/console/Application.php:117
Symfony\Component\Console\Application->run() at /Users/jakebooher/Sites/xf2/src/XF/Cli/Runner.php:63
XF\Cli\Runner->run() at /Users/jakebooher/Sites/xf2/cmd.php:15

xf:install [--user USER] [--password PASSWORD] [--email ] [--title TITLE] [--url URL] [--skip-statistics] [--clear]
First guess was that there was an issue with the socket value in my config.php, but I have that set to null so it shouldn't be looking for a socket file. Additionally if I update my config.php file to point to another XF install's database on my localhost everything works fine until I try to install an add-on, which triggers the same error as above

config.php:
PHP:
<?php

$config['db']['host'] = 'localhost';
$config['db']['port'] = '3306';
$config['db']['username'] = 'root';
$config['db']['password'] = '';
$config['db']['dbname'] = 'xf20';
$config['db']['socket'] = null;

$config['fullUnicode'] = true;


$config['debug'] = 1;

$config['development'] = [
    'enabled' => true,
    'fullJs' => true,
    'defaultAddOn' => 'ThemeHouse/Reactions',
];
$config['designer']['enabled'] = true;
$config['enableLivePayments'] = false;
No issues with anything else I have installed (xf1, wordpress, and countless other random things) so I'm at a complete loss at what's going on o_O
Edit: seems to be installing fine with web installer, so I'm guessing it's something goofy with my php-cli
 

Jake B.

Well-known member
#2
Reinstalled PHP and everything seems to be working now, was showing an older version of PHP 7.2 that I don't even have installed anymore when running php -v so something odd was going on with the symlink it created I guess
 
Top