1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Cannot reply to conversation with a user

Discussion in 'Troubleshooting and Problems' started by jeffwidman, Jan 8, 2015.

  1. jeffwidman

    jeffwidman Active Member

    A user just pm'd my account which has administrator permissions. For some reason, I can't reply to him. The "reply" box is just missing at the bottom of his PM.

    This is only appearing for this particular pm--I can start a new conversation with this user, and the reply box is showing for other conversations that he's sent me in the past.

    What could be causing this? Does it mean he's left the conversation? He's still listed as one of the participants... not sure if that means he's an active participant, or that at one time he was a participant.

    Along those lines, if I send a message to multiple people, and one of them leaves the conversation without replying, will they still be listed as a participant?

    I have a Xenforo 1.4 forum. Very vanilla install, few addons, none that touch PM functionality..
  2. Chris D

    Chris D XenForo Developer Staff Member

    Do you have any browser extensions installed? Specifically script or ad blockers?

    Just wondering if there's some content in the page that's triggering the various scripts to be blocked.
  3. Brogan

    Brogan XenForo Moderator Staff Member

    Did the member lock the conversation?
  4. jeffwidman

    jeffwidman Active Member

    No scripts/extensions. It's a good thought, I've done that before, just not this time.

    I didn't know this was even possible. I searched a bit, but not finding much other than functionality that requires add ons which I don't have. Is this built into core?

    I do have one suspicion--I had a manual SQL query that I ran go rogue on me... it didn't take down the site, but caused some random functionality. It was a long runnign update query on the xf_user table that kept timing out because it had a massive series of subselects (I was hunting spam using some complicated criteria). Didn't realize was a problem until some users reported various random problems. Restarted mysql and it was fine. I'm wonder if this might have locked the database slightly such that when the user sent the conversation, it updated some tables but not others? I ran the rebuild conversations cache script, but still had no reply box....

    Again, the weird thing is it's only being blocked for this one pm, but not other pms from this user. So I strongly suspect it was serverside.

    Anyway, not a huge deal, unless it pops up again, just anytime I see an issue like this I like to track it down in case it's symptomatic of a bigger issue that I haven't seen yet.
  5. Amaury

    Amaury Well-Known Member


    jeffwidman likes this.
  6. jeffwidman

    jeffwidman Active Member

    That's probably what happened.

    I doubt it was the database issue... when I think about that more, those should all be wrapped in transactions, so there shouldn't be halfway updates, only fully successful or not at all.
  7. zadow

    zadow Member

    This happend also for me now, this is very strange.
    However this user is just labeled registered use and not one with admin priv.
  8. Brogan

    Brogan XenForo Moderator Staff Member

    Administrator status is not required to leave or lock conversations.

Share This Page