• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not a bug Cannot Create new Node (Forum)

#1
Hello,

I was able to create categories for my forum but when I try to add a forum under the Category, it provides me with this error:

Mysqli statement execute error : Field 'post_rules_url' doesn't have a default value
  1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
  2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
  3. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
  4. Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1624
  5. XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1613
  6. XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1405
  7. XenForo_DataWriter->save() in XenForo/ControllerAdmin/Forum.php at line 127
  8. XenForo_ControllerAdmin_Forum->actionSave() in XenForo/FrontController.php at line 347
  9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  10. XenForo_FrontController->run() in /home1/esgnpro1/public_html/theclanpromotion/admin.php at line 13
I have absolutely no idea what it means by that. Can someone please help me?

Thanks,
New Customer :)

P.S I have installed a Enforce Rule app in a post it gives me this error:

  • The field 'moderate_messages' was not recognised.
  • The field 'require_post_rules' was not recognised.
  • The field 'post_rules_url' was not recognised.
  • The field 'post_rules_overlay' was not recognised.
I didn't check the box for the rules but it still gives me this.