1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Service Issue Can not login with Google on iOS

Discussion in 'Resolved Bug Reports' started by Dinh Thanh, Apr 13, 2015.

  1. Dinh Thanh

    Dinh Thanh Well-Known Member

    Hi!

    I can not login into Xenforo (both on my forums & Xenforo.com) with my Google account. When I click "Login with Google button", the page just get stuck there, there is no redirect to Google Login page.

    This happen only on iOS (I test with my iPhone 6 Plus, iOS 8.3).
    Thank you.
     
  2. whynot

    whynot Well-Known Member

    Very new OS
     
  3. Chris D

    Chris D XenForo Developer Staff Member

    Did you only test this with Chrome? I can't reproduce on Safari but I can on Chrome.
     
  4. Mike

    Mike XenForo Developer Staff Member

  5. digitalpoint

    digitalpoint Well-Known Member

    Ran into the same issue... Maybe it's combo of something in XF's implementation and Google's JavaScript somehow? I would think Google would have fixed an issue that only affects their own browser at this point.

    But additionally, Google+ account creation in Chrome on iOS works on non-XenForo sites. For example: http://weheartit.com/

    Without digging too much into the guts of the differences, one thing I notice with their implementation is they aren't doing the Google+ account association in a new browser window, while XenForo is. Maybe it's an issue with it trying to get back from that pop-up window?
     
    Dinh Thanh likes this.
  6. digitalpoint

    digitalpoint Well-Known Member

    I forgot I had built a Google+ implementation for XenForo from before XenForo supported it. I tested it with that one I built and it works fine with XenForo on iOS/Chrome, but I didn't use the JavaScript library to do it (the gapi.signin object). I used the server-side implementation where the user is redirected to the URL and then straight back (no popup window involved like the Google's JS library does). Might not be a bad idea to use that for authentication instead of the JS library (it's simpler to implement too).
     
  7. digitalpoint

    digitalpoint Well-Known Member

    I ended up making an addon that just uses the direct authentication URL, rather than use the JavaScript lib (since that's where the issue is)... all the backend stuff (like the code redemption) was left alone. We'll see if there are any issues in the next couple days, and I might release it if it doesn't make it into XenForo core.

    Nice to be able to have Chrome users sign up rather than how it works now (no error, no nothing... just nothing happens).
     
    markku and RoldanLT like this.

Share This Page