XF 1.4 Broken group assignment on registration

Holly Lisle

Member
At some point in installing and setting up my forum, I clearly screwed up.

The result of the screw-up is that folks signing up for my forum are not being assigned to the Registered group, which I set up so they had to make three posts that didn't get marked as spam before being promoted to Member.

Instead, these folks are either not being added to ANY group, or are being added straight to the Member group.

I have gone through all the documentation, and I cannot find out how to reset Registered as my default group.
 

Amaury

Well-known member
Are you using aMember by chance? Everyone's primary user group should be Registered upon registration.
 

Liam W

in memoriam 1998-2020
The default primary usergroup is always the 'Registered' usergroup (group 2).

Liam
 

Holly Lisle

Member
Not using any membership software at the moment---just naked XenForo.

At the point where my developer manages to build my proprietary front-end to integrate with Digital Access Pass (which already integrates with XenForo), I'll add those in. But having removed WordPress from my list of Software I Will Ever Use Again, that's still a few months out.

So these are folks just coming straight in and registering through XenForo.
 

Brogan

XenForo moderator
Staff member
All new registrations should be in the Registered user group by default.

You can confirm that by checking a newly registered member and seeing what their primary user group is.
It is possible to rename it so it could just be the name which is different?

Unless you have add-ons installed, which may be changing things.
 

Holly Lisle

Member
I have two addons, but they're both XenForo-original. Media Gallery and Resources.

I've done the install on this myself, and while I'm generally very good at doing software installs from the documentation, it is not outside the realm of possibility that I have done something ridiculous because of a mis-read or just making a dumb mistake.
 

Holly Lisle

Member
All new registrations should be in the Registered user group by default.

You can confirm that by checking a newly registered member and seeing what their primary user group is.
It is possible to rename it so it could just be the name which is different?

Unless you have add-ons installed, which may be changing things.
I set up a new user for myself. TestBob was added directly to Member (group 5), and was not added to Registered (group 2).
 

Brogan

XenForo moderator
Staff member
At the point where my developer manages to build my proprietary front-end to integrate with Digital Access Pass (which already integrates with XenForo), I'll add those in.
Has your developer changed anything in the code?
 

Holly Lisle

Member
Has your developer changed anything in the code?
My developer hasn't touched this. I set it up. I integrated it with DAP (Digital Access Pass)/WordPress for about three days, then killed the integration, deleted WordPress for being the devil, and closed DAP until such time as I have a non-evil CMS to use it with.

Because I had a protected login through DAP originally, I had Member set as the primary account in DAP. But the connection there is purely DAP to XenForo---there's no exchange of information from XenForo back to DAP, and with DAP down, there should not be any reason for Member to continue to be the default level.
 

Brogan

XenForo moderator
Staff member
Can you open a ticket with ACP (administrator log in) access so I can check to see what's happening?
 

Brogan

XenForo moderator
Staff member
I have just replied to your ticket.

As far as I can tell, everything is working as it should.
 
Top