MG 1.1 Bought XenGallery Addon Cannot install It

Agatha

Member
Sorry if this has been posted somewhere already ...

I bought xengallery, latest one, and I uploaded all folders to the right folders and when i try and install it say
"Please enter a valid file name. The requested file could not be read."
also when i try and upload from the computer it says "The files associated with this add-on could not be found. Please upload them and try again."

please help!
 

Chris D

XenForo developer
Staff member
No that wouldn’t have an effect.

What exactly did you upload and where did you upload it to. Provide screenshots if possible.
 

Agatha

Member
I upload the folders from js, library and styles/default to the js, library and styles/default folders in my root folder which is in 'forumsXenforo'

I also tried uploading the xml file using forumsXenforo/library/XenGallery/addon-XenGallery.xml
 

Chris D

XenForo developer
Staff member
They do seem to be in the correct place.

I think we've occasionally seen this with people using FileZilla.

Check what the file transfer type is set as. I think there's three options. Auto, ASCII and Binary. Generally Auto should work, but otherwise make sure Binary is selected:

upload_2017-6-28_18-8-35.png

(I borrowed this screenshot from elsewhere, and things might have changed now).

Alternatively, use a different FTP client such as WinSCP and try again.
 

Agatha

Member
Thanks..I tried that. I'm wondering if the fact that my root is in a folder named 'forumsXenforo' ? I dunno..I uploaded it..same stuff
 

Chris D

XenForo developer
Staff member
Not that would cause an error like that.

Have you tried a different FTP client?
 

Agatha

Member
Sorry to be a dunce but how do I download that other FTP client? I tried searching for WinSCP and got a bunch of adds..

thanks again!!
 

Agatha

Member
weird thing is, the xml file is in the library, but when I try to enter enter library/XenGallery/addon-XenGallery.xml and submit the form ot wont work. I also tried forumsXenforo/library/XenGallery/addon-XenGallery.xml

still would not work.
 

Chris D

XenForo developer
Staff member
Please shoot us a quick message via the contact form: Contact Us

Once you have done that, you'll be redirected to a form where you can submit information in the "Sensitive Data" field. Please add your FTP login and Admin CP login details in there.

Obviously you don't have active support right now but I think it's right we stretch that rule slightly so you can actually use your new purchase without much more delay and get you up and running :)
 

Agatha

Member
Wow thanks so much! You guys are so helpful.

I submitted a ticket but there was no sensitive data area...do I just wait for an email?
 
Top