1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Blank Alerts

Discussion in 'Troubleshooting and Problems' started by xenTheory, Aug 6, 2013.

  1. xenTheory

    xenTheory Active Member

    The built in Alerts function produces an error - an alert is made by there is no link, no text and the box isn't clickable. I've also tested the bd tag me addon and the same problem occurs.

    Anyone have any ideas? It's a simple 1.15 to 1.2 upgrade and produced no errors, there were also no server errors logged.

    I've also made a post in the bd tags area, however the problem occurs with or without that enabled. Not sure if that would be considered a duplicate post or not?

    Last edited: Aug 6, 2013
  2. xenTheory

    xenTheory Active Member

    Here's a further example, taken from the profile page.

  3. Chris D

    Chris D XenForo Developer Staff Member

    This is usually caused by an add-on.

    Is there anything logged in the Server Error Log in the Admin CP?
  4. xenTheory

    xenTheory Active Member

    Hi Chris, I've checked the server logs and there is nothing at all there - I cleared it after upgrading to 1.2 a few days ago and no errors since.

    @Chris Deeming

    Here's a list of all addons, whether enabled or not, that are currently installed.

    Last edited: Aug 6, 2013
  5. Chris D

    Chris D XenForo Developer Staff Member

    The alerts that have no text.

    What are they being generated by? Only by TagMe?

    Or are they being generated by default functionality too such as quotes, replies and likes?
  6. xenTheory

    xenTheory Active Member

    I've completely removed bd tag me now so only the default functionality is left. I've just tested using an admin account and standard account - Liking a post gives the correct result in the Alerts area, so I think it's just when using @.
  7. Chris D

    Chris D XenForo Developer Staff Member

    So those blank ones are where someone has tagged you using the built in XF 1.2 functionality?

    Can you check your Admin CP for this template: alert_post_tag
    And this phrase: x_tagged_you_in_post_in_thread_y

    Do they exist? Do they both have some sort of content in them?
  8. xenTheory

    xenTheory Active Member

    alert_post_tag doesn't exist on the custom style or the default o_O
  9. Mike

    Mike XenForo Developer Staff Member

    Go to <url>/install/ and reimport the master data.
    D.O.A., graham_w and Chris D like this.
  10. xenTheory

    xenTheory Active Member

    That appears to have fixed the issue. Thank you :) Can I ask why that wasn't done as part of the 1.2 upgrade process? I'm guessing it should have been but obviously something didn't complete, although no errors were produced.

    Whilst I'm talking about the 1.2 upgrade.... the ajax loader image didn't work when upgrading. Not a big issue but thought it worth mentioning.
  11. xenTheory

    xenTheory Active Member

    Also, @Chris Deeming would you mind removing that URL from your post?
  12. Chris D

    Chris D XenForo Developer Staff Member

    Any particular reason? Everyone has the same install URL.

    It's the first time we've seen this issue. I even checked the old version of Tag Me in case that had a template of the same name (which would have been deleted when you uninstalled it) but Tag Me's template is called alert_post_tagged . Slightly different. Can't think what else would cause it though, unless that template did exist and was assigned to that add-on or if it was deleted manually after the upgrade was complete.

    We'll have to mark it "unexplained" I think :)

    Not sure about the ajax loader image. Pretty sure I've seen it during my upgrades.
  13. xenTheory

    xenTheory Active Member

    I know everyone has the same URL but not everyone knows about it... unless this area of the forum is not visible to the public? Call it paranoia :p

    Before the upgrade I disabled all the addons and removed any that weren't of use or that were no longer required due to features be added to core functionality. I'm not sure about the ajax loader image either, it doesn't really matter but made the window stretch to around 1000px long - I tried it on two upgrades (one main and one dev) so I'm guessing it's server related. However I do have another license and that's on another server so I'll see if that does the same when upgrading. If it does then it's me related :notworthy:

    Again thank you both for your help. Support really is top notch from the community and staff.
    Chris D likes this.
  14. Martok

    Martok Well-Known Member

    You best edit your post where you quoted Chris as the URL is still visible there. :)
    Chris D likes this.
  15. xenTheory

    xenTheory Active Member

    Just noticed Chris removed the post, I've done the same :)
  16. Jesepi

    Jesepi Well-Known Member

    This just happened to me as well, was missing the alert_post_tag template. Mike's suggestion fixed it.
  17. graham_w

    graham_w Active Member

    Thanks - this fixed my issue too :)
  18. Martok

    Martok Well-Known Member

    This has also happened to me (now fixed with re-importing the Master Data) and it was the alert_post_tag that was missing .

    Comparing my list of add-ons to those of the OP, the ones we have in common are (some with different version numbers):

    ******* - Change Threads/Posts Owner 1.0.4
    Last Post Avatar by Waindigo 1.1.8b
    Nodes As Tabs 1.2.2
    [8wayRun.Com] XenPorta (Portal) 1.6.0
    [bd] Tag Me 2.0.1

    I think the blank alerts have only happened recently though, which I guess would rule out many of these as they have not been changed for a few weeks. The only exception to that is Nodes As Tabs which was updated at the end of September. Looking back in my emails, I received an email about a tag in a post just before updating Nodes As Tabs and I'm sure I'd have spotted a blank alert then.

    Could Nodes As Tabs have anything to do with this? I'd have thought not, I don't think it has anything to do with the alert_post_tag template?

    The only other possibility that I can think of (and would be more likely) is Tapatalk, which I uninstalled on 17th October. Now I know that it uses alerts and searching the install XML file I found

        <template title="alert_post_tag" version_id="8" version_string="1.1.4"><![CDATA[{xen:phrase x_taged_you_in_post_in_thread_y,
        'name={xen:helper username, $user, 'subject'}',
        'title=<a href="{xen:link posts, $content}" class="PopupItemLink">{xen:helper threadPrefix, $content}{$content.title}</a>'}]]></template>
    (and yes, they have misspelled the phrase!)

    Could it be uninstalling Tapatalk that has removed the alert_post_tag template? The above is the only reference I can find to the template in Tapatalk, I can't see a reference to removing a template unless I should be looking for something less obvious?
    graham_w likes this.
  19. graham_w

    graham_w Active Member

    I think you're onto something. I recently removed Tapatalk also. Apart from [bd] tag me i don't have any of the addons you do.
  20. MattW

    MattW Well-Known Member

    Same here! I'm also getting this since uninstalling TapaTalk!

Share This Page