• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

[bd] Forum Watch

#63
I am willing to, and indeed have, make contributions to add ons I use. I will say that it is tougher in xenforo without an add on manager.

I am happy to contribute to this one. Just let me know where to send.
 

xfrocks

Well-known member
#64
This add-on has just been upgraded ;)

Code:
Version 1.0 (released Dec 13th, 2011)
1.0.1 Added support for full message in emails
1.0.2 Honors user ignore settings
1.0.3 Check for thread read status before sending notifications (mimics XenForo's)
 

Andy.N

Well-known member
#66
This add-on has just been upgraded ;)

Code:
Version 1.0 (released Dec 13th, 2011)
1.0.1 Added support for full message in emails
1.0.2 Honors user ignore settings
1.0.3 Check for thread read status before sending notifications (mimics XenForo's)
opps

Add-on IDs must be unique. The specified ID is already in use.
 

Andy.N

Well-known member
#68
Well, I changed the id a bit. Please remove before install it again. No data will be lost.
Tried to uninstall the old Forum Watch version (after upload and overwrite the file), now I got this error
Security error occurred. Please press back, refresh the page, and try again.
 
#70
I got the same id error, so I uninstalled the old version and installed the new one. But in my "Installed Add-ons" in the admin control panel, it says:

[bd] Forum Watch 0.9.7

Did it not install the new version, or did the version number not get updated?

p.s.: I'm REALLY looking forward to getting this mod up on my forums! :)
 

xfrocks

Well-known member
#71
I got the same id error, so I uninstalled the old version and installed the new one. But in my "Installed Add-ons" in the admin control panel, it says:

[bd] Forum Watch 0.9.7

Did it not install the new version, or did the version number not get installed?

p.s.: I'm REALLY looking forward to getting this mod up on my forums! :)
Congratulation on your upgrade!
Well, it was my mistake. I didn't update the version number. If you uninstalled and installed it with the new .xml file, it's 1.0 now. I have re-uploaded the package. Sorry for the inconvenience :p

PS: If you want to have correct version number, just download the new package and import the xml (no uploading or uninstalling required).
 
#72
(I doubt that this has anything to do with the Forum Watch update, but since I noticed it shortly after installing the update I thought I'd ask if anybody else is seeing the same problem.)

My global RSS feed (the icon on the footer) started failing. Clicking on it (/forums/forums/-/index.rss) returns:

<errors>
<error>
<![CDATA[ The requested page is unrepresentable as RSS. ]]>
</error>

</errors>
 

xfrocks

Well-known member
#73
(I doubt that this has anything to do with the Forum Watch update, but since I noticed it shortly after installing the update I thought I'd ask if anybody else is seeing the same problem.)

My global RSS feed (the icon on the footer) started failing. Clicking on it (/forums/forums/-/index.rss) returns:

<errors>
<error>
<![CDATA[ The requested page is unrepresentable as RSS. ]]>
</error>
</errors>
It got this on one demo board and reuploading the files overwriting fixes it. Can you redownload the package and do that? To be even more bullet proof, delete the directory library/ForumWatch before uploading!
 
#75
I have a couple of questions about the behavior of this mod:

1) I have a new thread on my forum, and I got the email notification (with full text; thanks!) for the first two posts in the thread, but I haven't seen the following six posts yet. Should they have gone out immediately, or will they be on a periodic (cron?) schedule?

2) Will users see their own posts?

Thanks for your help, and thanks for the mod!
 

xfrocks

Well-known member
#76
I have a couple of questions about the behavior of this mod:

1) I have a new thread on my forum, and I got the email notification (with full text; thanks!) for the first two posts in the thread, but I haven't seen the following six posts yet. Should they have gone out immediately, or will they be on a periodic (cron?) schedule?

2) Will users see their own posts?

Thanks for your help, and thanks for the mod!
If you haven't read the thread since the last email, the system won't send you email anymore. This behavior is the same as XenForo's watch thread feature.

And by the way, this add-on doesn't implement any kind of queue. Email is sent out right after the post is submitted.
 
#78
If you haven't read the thread since the last email, the system won't send you email anymore. This behavior is the same as XenForo's watch thread feature.
My email notification users seem split on this one thus far -- some of them want to see an email for every post, regardless of whether they've viewed the thread. (I suspect they may change their minds on this as the forum traffic continues to grow!)

Is this something that could be added (as an option?) to this add-on, or is it something that XenForo is mandating?

Thanks again for the great add-on!
 

xfrocks

Well-known member
#79
I thought we were going to override that behavoir? :)
My email notification users seem split on this one thus far -- some of them want to see an email for every post, regardless of whether they've viewed the thread. (I suspect they may change their minds on this as the forum traffic continues to grow!)

Is this something that could be added (as an option?) to this add-on, or is it something that XenForo is mandating?

Thanks again for the great add-on!
Hmm, yeah. The old version ignores that data. Doing it that way may cause problem with high traffic board so in 1.0 I reconsidered it and added the check. Probably I will add an option for that :)
 
#80
In my forum it displays all the forums if I go to watched, and there are no options to select or edit there.

It doesn't seem a template issue as it hapens will all 3 installed.

Any clue?
 

Attachments