1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Banning IP does nothing

Discussion in 'XenForo Questions and Support' started by polle, May 20, 2014.

  1. polle

    polle Active Member

    I added today an IP from a spammer to the block and its not working, it comes back and reply to 20 posts with spam without any problems.

    What to do ?

    Thanks.
     
  2. Liam W

    Liam W Well-Known Member

    Are you sure they're using the same IP? It really isn't hard to change your (visible) IP.

    Did you ban the spammer?
     
  3. polle

    polle Active Member

    Well, for IP its the same one when clicking it. How can I know if theres another one and they are masking it ?

    I banned the IP, its an open thread that anyone can post. So, theres no user, just IP.

    Thats the problem, that banning the IP does nothing.
     
    Last edited: May 20, 2014
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Banning IP addresses works in my experience.

    How are you adding it to the field?
    How does it appear in the content field for the posts in question?
     
  5. polle

    polle Active Member

    Admin>Users>Ban IP.

    Is there another way to add them ?

    I don't understand what you mean by that, but I go to a thread I see that X (guest user) posted buy viagra. Click IP, copy and paste it in the admin.

    The spammer keep coming after I delete all posts, so the IP its not being banned.

    Thanks.
     
  6. polle

    polle Active Member

    Anyone ?
     
  7. Tracy Perry

    Tracy Perry Well-Known Member

    I wonder if the banned IP is only to prevent registration from that IP? If it is, and you allow guest posting then that may be the problem. If so, you can block at iptables level (just drop that IP) or place all guest posts into moderation.
     
  8. Try banning their email address.
     
  9. Tracy Perry

    Tracy Perry Well-Known Member

    If they are posting as a guest then they don't have an email address. ;)
     
    polle likes this.
  10. polle

    polle Active Member

    Today its happening no stop. I banned the range of IP addresses and nothing.

    91.200.*

    And the comments come in.

    Why is the IP block thing not working ?

    Thanks.
     
  11. Tracy Perry

    Tracy Perry Well-Known Member

    Want to really mess with them use the discourage. :sneaky:
     
  12. Mike

    Mike XenForo Developer Staff Member

    How have you identified what IP to ban? From within XenForo?
     
  13. whynot

    whynot Well-Known Member

    Ban that IP in your site's control panel.(cPanel, etc.)
     
  14. polle

    polle Active Member

    here:

    here:


    Thanks.
     
  15. polle

    polle Active Member

    Yeah or by htaccess. The thing here is why XF IP ban is not working and not how to do it in other places.

    Thanks.
     
  16. Mike

    Mike XenForo Developer Staff Member

    Does it work if you ban your own IP?

    Are you now running the most recent release? Can you confirm the issue with add-ons disabled?
     

Share This Page