• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Banning IP does nothing

polle

Active member
#1
I added today an IP from a spammer to the block and its not working, it comes back and reply to 20 posts with spam without any problems.

What to do ?

Thanks.
 

Liam W

Well-known member
#2
I added today an IP from a spammer to the block and its not working, it comes back and reply to 20 posts with spam without any problems.

What to do ?

Thanks.
Are you sure they're using the same IP? It really isn't hard to change your (visible) IP.

Did you ban the spammer?
 

polle

Active member
#3
Well, for IP its the same one when clicking it. How can I know if theres another one and they are masking it ?

I banned the IP, its an open thread that anyone can post. So, theres no user, just IP.

Thats the problem, that banning the IP does nothing.
 
Last edited:

Brogan

XenForo moderator
Staff member
#4
Banning IP addresses works in my experience.

How are you adding it to the field?
How does it appear in the content field for the posts in question?
 

polle

Active member
#5
How are you adding it to the field?
Admin>Users>Ban IP.

Is there another way to add them ?

How does it appear in the content field for the posts in question?
I don't understand what you mean by that, but I go to a thread I see that X (guest user) posted buy viagra. Click IP, copy and paste it in the admin.

The spammer keep coming after I delete all posts, so the IP its not being banned.

Thanks.
 

Tracy Perry

Well-known member
#7
I wonder if the banned IP is only to prevent registration from that IP? If it is, and you allow guest posting then that may be the problem. If so, you can block at iptables level (just drop that IP) or place all guest posts into moderation.
 
#8
Admin>Users>Ban IP.

Is there another way to add them ?



I don't understand what you mean by that, but I go to a thread I see that X (guest user) posted buy viagra. Click IP, copy and paste it in the admin.

The spammer keep coming after I delete all posts, so the IP its not being banned.

Thanks.
Try banning their email address.
 

polle

Active member
#10
Today its happening no stop. I banned the range of IP addresses and nothing.

91.200.*

And the comments come in.

Why is the IP block thing not working ?

Thanks.
 

Mike

XenForo developer
Staff member
#16
Does it work if you ban your own IP?

Are you now running the most recent release? Can you confirm the issue with add-ons disabled?