Auto Complete Location

Auto Complete Location 6.0

No permission to download

JustinHawk

Well-known member
I've had to disabled the Auto Fill Location (IP) setting for now as I'm getting lots of signups with missing info in the following format:

, , GB
Hi can u pm me the registration IP of the users who have location like this will be helpfull in investigating it ;)
 

RobinHood

Well-known member
Hi guys,

I have [XFA] Members Map [Paid] 1.1.2 and Auto Complete Location 4.0 installed

I think there's some kind of conflict or one of them has an bug that is breaking the 'Required' functionality of the 'Location' field at registration.


When disabling them I'm left with an completely unwanted lat and long fields on the user registration form too.

View attachment 142112


This is quite frustrating as I can't disable them both, and if I leave them enabled I'm getting users registering without completing the location field as required.

Can you please advice if there's any bugs/conflicts and advise how to fix?

Thanks
 

JustinHawk

Well-known member
When disabling them I'm left with an completely unwanted lat and long fields on the user registration form too.

View attachment 142112


This is quite frustrating as I can't disable them both, and if I leave them enabled I'm getting users registering without completing the location field as required.

Can you please advice if there's any bugs/conflicts and advise how to fix?
You can disable that custom user fields in
Users > Custom User Fields , I will remove that field in upcoming version as its of no use for you guys.

Also since this add-on is simply based on template modifications I can't say much on breaking of required functionality of the location field but will definitely give a look over that.

Regards,
 

JustinHawk

Well-known member
@JustinHawk , i got same problem on my board. How to fix it? http://forum.bestflowers.ru/register .
Atm there is no fix for it yet, the issue is maxmind has not updated it's geoiplite database yet (free one ofc), once maxmind updates it database, freegeoip will also get its database updated and it will automatically start working again

Or find any other website which provide same service like freegeoip.net which is having better database and let me know I will try to integrate it into this.
 

Rudy

Well-known member
Is there a way to force users to select a choice from the list, as opposed to typing in their own location? In other words, we want to get rid of members adding "nonsense" locations to their profile, and use a legitimate entry from the list. I get the listing of location names with no problem, but I can still override and type anything I want in the Location field, and save it.

I know it is possible since there are other sites out there that will accept only a validated input.
 

Wesker

Well-known member
Having issues getting this to work with the UIX theme. The auto popup location doesn't display and it's stuck (won't let you enter any text fields). It works in the default theme. Anyway around this?
 

JustinHawk

Well-known member
Having issues getting this to work with the UIX theme. The auto popup location doesn't display and it's stuck (won't let you enter any text fields). It works in the default theme. Anyway around this?
I will check it out in few days
 

Wesker

Well-known member
I will check it out in few days
I got it working. It was indeed a theme issue. Had to modify a few things with the theme.

Have a question. On the members profile inside their thread or post, where do you modify the CSS for this where it's displaying the location of the user?

Specifically referring to the postbit.
 

JustinHawk

Well-known member
I got it working. It was indeed a theme issue. Had to modify a few things with the theme.

Have a question. On the members profile inside their thread or post, where do you modify the CSS for this where it's displaying the location of the user?

Specifically referring to the postbit.
I don't modify anything related to postbit at all and I think I had written all the templates being modified in overview of resource.
 

PumpinIron

Well-known member
I had to disable the "Auto Fill Location (IP)" option, because it was autofilling the sign-up form with the wrong info.

Here's a screenshot:

Screen Shot 2017-04-28 at 9.01.13 PM.png

It's autofilling as "Oregon, Wisconsin, United States", when in fact my IP address (and the computer I was using the sign-up form from) is located in Salem, Oregon, United States.

I verified my IP address using a Google search, just to make sure:

Screen Shot 2017-04-28 at 9.04.09 PM.png

So in other words, the "Auto Fill Location (IP)" option is not working correctly.
 
Top