Article and Forum Connect: XenForo and WordPress

Article and Forum Connect: XenForo and WordPress 1.0.6

No permission to download

Sanmu

Active member
Thank you so much for your answer. I am trying to delete the site language(Eng) in WordPress. Hope this can solve the problem.

This plugin detects language which is used in WordPress rather than in Xenforo, right?
 

mattrogowski

Well-known member
That would be a limitation of WordPress then, there won't be much we can do about that. You should still be able to translate the text within this plugin though.
 

Sanmu

Active member
Installed "Loca Translate" Plugin, try to translate but failed. Any suggestions how to translate this plugin?
 

mattrogowski

Well-known member
Again it would just be the same way any other text or plugin is translated in WordPress. I don't have any specific directions on how to do it as it's not specific to the plugin, it's WordPress functionality. You would probably be better asking on the WordPress support forums.
 

mattrogowski

Well-known member
I found there were a few places where text was hardcoded, this build makes them use the translate function - see if this makes any translations you set up pull through. If it doesn't, then I'd recommend asking on the WP or Loco Translate forums for how to use it to set up translations. I can see that some plugins come with translation templates, this isn't something we currently provide, but WP should have a way to set up translations for plugin text.
 

Attachments

  • article-forum-connect.zip
    1.1 MB · Views: 2

Sanmu

Active member
Thank you for your help.
Installed this new version article-forum-connect, but it doesn't help, the problem is that the Loco translate plugin can not read the below words:
1650456778914.png
1650456796396.png
 
Last edited:

Sanmu

Active member
I found a way to change that. Just opened the src file of this plugin.

Article forum connect - src - templates -

Then I changed some of the phrases.

I don't know how to code, but it works.

1650459827947.png
 
Last edited:

Sanmu

Active member
1. I am using version 1.0.3. Once I comment on the article, I got the same 2 comments instantly. Reinstalling this plugin has not helped. It is really annoying. Please help:)

2. Now this plugin starts to work on my website. Does this plugin only provide 150 words with 3 dots reposts on forum?

3. If a Xenforo user is without an avatar, then he comments on WordPress it will look really bad.

If I purchase a plus version, this can be improved?

Checked website macrumors, they seem don't have limited for reposting on forum https://forums.macrumors.com/threads/apple-releases-new-firmware-for-magsafe-battery-pack.2342308/
 
Last edited:

mattrogowski

Well-known member
1. I can't reproduce that, it only did it once for me, but may happen if the submit button is clicked twice. I'll look into disabling it on click so you can't do that.

2. It uses the post excerpt that WordPress generates, the problem with trying to use the full post is that it'd have to strip out all non-text content, and I'm not aware of a WordPress function that does that

3. I'll apply a fix for that so it defaults to a generic image for users with no avatar

The plus version would have resolved the avatar issue as it sends the user's email address in the API response so I can generate a gravatar, but the plus version can't be purchased on its own, it's only available in our Resources subscription. Also, MacRumors uses our older XPress platform, not this plugin.
 

Sanmu

Active member
1. Please try to comment from the wordpress side rather than from forum, you will instantly get 2 same comments. Try to comment some like "Test from wordpress" rather than "Test".

2. Great to know.
3. Great to know.

Thank you so much for looking at these questions.
 

mattrogowski

Well-known member
I did it from the WP side and it was fine, it looks like the button is being clicked twice. I've made a change to disable the button after clicking it the first time so it can't be clicked twice.
 

Sanmu

Active member
Sorry, I just did more tests. If I comment no-english, it duplicated comment instantly. Comment in Eng is ok, no duplication.
 

mattrogowski

Well-known member
I don't think the language has anything to do with it, if it's posting twice it means it's doing 2 API calls which means there's 2 form submissions. It doesn't detect the language and do anything differently or work differently if certain characters are present. Once the new version is released that stops the button being clicked twice, it should stop doing it.
 

ThemeHouse

Well-known member
ThemeHouse updated Article and Forum Connect: XenForo and WordPress with a new update entry:

Version 1.0.5 Released

1.0.1
  • Checks if email address is set in comments before using it for a gravatar
  • Uses the remember me cookie as well as the session cookie

1.0.2
  • Get comments count from thread reply count
  • Fixes permissions on post voting
  • Fixes issue with default thread config not being populated
  • Fixes issue with undefined avatar variable
  • Fixes issue with comments template not being loaded

1.0.3
  • Fixes issue with long post...

Read the rest of this update entry...
 

Sanmu

Active member
Great update, prevented double comment form submission:D

But if a forum user doesn't have an avatar, it still shows this:
1650973333590.png
If you can provide an option to disable the avatar or set a default avatar for comment users, then this would be a great solution.
And I see from the site portal, the comment counter stopped showing the real number of comments.
1650973743939.png
Please continue to fix these 2 bugs, many people who use wordpress will thank you for your great contributions.
 
Last edited:

mattrogowski

Well-known member
Are you definitely on 1.0.5? It does set a default avatar, it shouldn't be possible to still be a broken image. Does the file wp-content/plugins/article-forum-connect/public/img/avatar.png exist on your site? It sets the avatar to this URL and only overrides it if the API returns a user's avatar, so shouldn't ever be a broken image now if you have that image there and uploaded all the new plugin files.

Also the comments count gets updated from the number of replies in the thread, I can't see any issues with that on my installation either. Make sure you have definitely uploaded all the new files, it sounds like they've not been updated.
 
Last edited:

Sanmu

Active member
Installed the plugin by updating and then replaced "AudentioForumConnect" and "templates" with my translation.

The file wp-content/plugins/article-forum-connect/public/img/avatar.png was on my site.
1650986173966.png
Updated: I have tested more than 10 comments, now got more info

1. Deleted the plugin and installed it again. Now I got an avatar!
Checked my WP settings, the function: only login users can leave a comment. was enabled.

2. After I disable the above function, allow not login user to comment, the site portal comment counter starts to work.

3. But when I comment from WordPress side, it still creates 2 same comments instantly. And the wordpress portal counts 1 for this comment.

4. When a comment was made from forum, the wordpress stops count it, but the comment was displayed under the article in wordpress.

I can confirm the avatar now starts work if a user doesn't have it before.
 
Last edited:

mattrogowski

Well-known member
You shouldn't have needed to delete or uninstall it first, it would have pulled the default avatar through by just uploading the new files.

The double commenting issue is what we discussed before - your theme has code to submit the comments form to the default WP comments URL. There's really not a lot I can reliably do about this that won't break other functionality in the plugin.

The comments count is updated whenever you load the WP post. When it pulls the comments in, it updates some meta data on the post to store the number of replies to the XF thread, and it uses that to display the comment count. I can see on your site it's not doing that, but I'm not seeing any problems with it on my installation, so either your theme is doing something strange, or you still have outdated files.
 
Top