1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

An unexpected error occurred. Please try again later -> After Upgrading To PHP 5.

Discussion in 'Server Configuration and Hosting' started by TheBigK, May 29, 2013.

  1. TheBigK

    TheBigK Well-Known Member

    Mod Note: The Thread Title Need PHP version : 5.4.15, instead of 5. Sorry :)

    I'm performing a test upgrade of my latest Xenforo on a clone server. I successfully upgraded php from 5.2 -> 5.4.15 and the other test server details are as follows.

    Apache version: 2.2.24
    PHP version:5.4.15

    MySQL version: 5.0.96-community

    After upgrading the site, I'm getting "An unexpected error occurred. Please try again later." on the site.

    I've few questions:

    1. What's the right way to fix that error?

    2. What's the latest MySQL version I can upgrade to without worrying about errors.

    3. If there are issues running 5.4.15; which is the latest PHP I can upgrade to without worrying about errors?
  2. ENF

    ENF Well-Known Member

    1) Need more details. Check your error logs for PHP and your server.

    2) We've been running MySQL 5.5.30 without any issues. (test box has 5.6.x, not really done much with it yet)

    3) No problems noted with 5.4.15 (that I have seen).

    Overall, you shouldn't have any problem with the PHP version. Something may be misconfigured somewhere.

  3. TheBigK

    TheBigK Well-Known Member

    1. I had server admin look at the logs; but there's nothing he could find. I'll check with him again.

    2. By the way - the upgrade process is smooth; right? Do we need to change anything while heading over from PHP 5.2 - 5.4?
  4. SneakyDave

    SneakyDave Well-Known Member

    What version of xF? There is a small bug in versions 1.1.3 and prior (maybe 1.1.4?) that if you have debug enabled in config.php, it throws some error notices in the admin.php section, but I don't think that would result in the xF default you're seeing.

    I made the upgrade from 5.2 to 5.3, and eventually to 5.4, but I don't recall anything out of the ordinary other than the debug problem above.
  5. TheBigK

    TheBigK Well-Known Member

    1.1.5. I read a few posts that say it works perfectly. I'm however not able to go beyond
  6. SneakyDave

    SneakyDave Well-Known Member

    Can you get into your admin.php section and see if there are any error logs there, or do you get the same error message?

    I assume you are running apache and it's been restarted?
  7. TheBigK

    TheBigK Well-Known Member

    Nope, getting the same error all over the site. Even admin.php throws the same error. I even checked the page source of the error - but it's got just the message and nothing else.

    Currently MySQL is being upgraded.
  8. TheBigK

    TheBigK Well-Known Member

    Yeah, we did try restarting apache. Right now MySQL is being upgraded and my server admin says -

  9. ENF

    ENF Well-Known Member

    yeah, then you'll need to wait.
    I was going to suggest checking that the PHP libraries for MySQL were loaded correctly after the PHP upgrade.
    SneakyDave and TheBigK like this.
  10. The Forum Heroes

    The Forum Heroes Well-Known Member

    Are you using anything like Memcache or APC, if so the PECL for them needs to be recompiled.
    TheBigK likes this.
  11. TheBigK

    TheBigK Well-Known Member

    I'll check with the admin.

    MySQL upgrade has failed in the meantime. The admin's looking into it.
  12. TheBigK

    TheBigK Well-Known Member

    Thanks a lot folks! Recompiling memcached for PHP solved the error. The site seems to be working fine. Will perform upgrade on my live server soon :).
    The Forum Heroes likes this.
  13. The Forum Heroes

    The Forum Heroes Well-Known Member

    Good deal, glad my suggestion helped :)
  14. TheBigK

    TheBigK Well-Known Member

    One more question :)

    I'm trying to install lightspeed on my server which currently runs apache. Is it necessary to stop apache (or uninstall it) before I attempt to install lightspeed? Or will lightspeed automatically replace apache on port 80?
  15. The Forum Heroes

    The Forum Heroes Well-Known Member

    Are you using the cPanel plugin or compiling by source?
  16. TheBigK

    TheBigK Well-Known Member

  17. The Forum Heroes

    The Forum Heroes Well-Known Member

  18. TheBigK

    TheBigK Well-Known Member

    ...and it installs the server for me, right? o_O or I'll still need manual install?
  19. TheBigK

    TheBigK Well-Known Member

    Yeah it does! WOW!

    Mike, You're Jake Bunce II!
    SneakyDave likes this.
  20. The Forum Heroes

    The Forum Heroes Well-Known Member

    You'll need to install it, but it is easier and you get a GUI panel..

    Ok first in ssh do nano /var/cpanel/cpanel.config

    find maxmem= and change 256 to 1024 and save

    service cpanel restart

    Ok go into WHM and go to the LS panel link

    Ok after you see the link, click it..


    Starting from the left your gonna be doing all 3 circles you see in the screenshot

    Ok 1st one, if you already have a key enter it there. If not browse to where you downloaded trial.key on your computer. Do not switch from Apache yet.

    Once that installs you'll see it says 4.2.2 and new version in avail.. that's because it is a bug, click it and then click on force reinstall, now you'll really have 4.2.2 and not the visual bugged 4.2.1

    ok second circle.. enable easy apache intergration

    third circle, recompile php.. be sure to check off the check box too.

    Once done, click the change to litespeed link and your off!
    SneakyDave likes this.

Share This Page