1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Alerts are not removed when a profile post is deleted

Discussion in 'Resolved Bug Reports' started by urban75, Oct 14, 2010.

  1. urban75

    urban75 Member

    I've received an alert that someone has written a message on my profile, but when I click on the link in the alert I get:

    XenForo Community - Error
    You do not have permission to view this page or perform this action.

    I can , however, access my profile via the drop down.

    Any ideas?

    *edit: I wish there was a quote code available in the posting box!
  2. urban75

    urban75 Member

    Oh, and although I had the alert saying that "--- wrote a message on your profile" there is in fact nothing on my profile.
  3. Sador

    Sador Well-Known Member

    My guess would be that the person that wrote it (soft)deleted his message again, which made the link point toward something that isn't visible to regular users anymore, therefore giving the permission error.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    The post has been deleted by the author.
  5. urban75

    urban75 Member

    Couldn't the software automatically remove the alert if the message no longer exists, or at least inform the user that the message has been deleted?

    I imagine board admins will get mightily pestered if their users keep getting the same thing...
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Just had a chat with Mike and he wants to look into this so I've edited the thread title to more accurately reflect the issue.
  7. urban75

    urban75 Member

    This thread's moving all over the place!
  8. DoctorWatsOn

    DoctorWatsOn Well-Known Member

    Oops, sorry that was me. :oops:

    I posted on your profile page in error instead of starting a PC, so I deleted the profile post.

    Although, of course, it would be handy if the system also deleted the alert.

Share This Page