Alert Improvements by Xon

Alert Improvements by Xon 2.10.13

No permission to download
Xon updated Alert Improvements by Xon with a new update entry:

2.8.6 - Bugfix & maintenance update

  • Fix an alert count query being deadlock prone.
  • Rip out XF2.0 support & Content Ratings for XF2.0 support
  • Update various reaction summary phrases to be more consistent with singular reaction alerts
  • Update alert mark-as-read option hint phrases to be hopefully less confusing
  • Add per-alert "mark read" link (like "mark unread", it uses ajax to reload the alert)
  • In Alerts pop-up page
    • Fix that just read alerts where being pushed under unread alerts when splitting...

Read the rest of this update entry...
 
I haven't added javascript to the 'mark read' for all alerts and it triggers a reload, but with the individual per mark-read link it isn't as pressing. I'm working on implementing a version but it is going onto the back-burner to finish up Report Centre Essentials support XF2.2+ and User Essentials for XF2.2+
 
Xon updated Alert Improvements by Xon with a new update entry:

  • Add per-alert "mark read" link (like "mark unread", it uses ajax to reload the alert)
Hi there,

when using the link, the alert updates successfully - however, the "Mark read" text stays the same. It only changes to "Mark unread" after reloading the page.

And the "Mark all read" link now redirects to a page instead of displaying in a modal? Is that intended?
 
It also looks like you have duplicates:
Code:
                    <xf:if is="$showSelectCheckbox && $alert.is_new">
                        <li><xf:fa icon="fa fa-star" class="unread-indicator-icon" aria-hidden="true" title="{{ phrase('sv_unread_alert')|for_attr}}" /></li>
                    </xf:if>
 
Last edited:
The phrases are still the same.
"On...."
Which phrases? I really need more details, as that search prefix is essentially unusable.

It also looks like you have duplicates:
Code:
                    <xf:if is="$showSelectCheckbox && $alert.is_new">
                        <li><xf:fa icon="fa fa-star" class="unread-indicator-icon" aria-hidden="true" title="{{ phrase('sv_unread_alert')|for_attr}}" /></li>
                    </xf:if>
This is deliberate. In the alerts list it is shown in inline to the subtitle row. In the alerts pop-up it is under the avatar and uses variables to control which is selected.

Hi there,

when using the link, the alert updates successfully - however, the "Mark read" text stays the same. It only changes to "Mark unread" after reloading the page.

And the "Mark all read" link now redirects to a page instead of displaying in a modal? Is that intended?
Packaged the wrong version of the javascript and some template bits. Will release a patch soon
 
Which phrases? I really need more details, as that search prefix is essentially unusable.


This is deliberate. In the alerts list it is shown in inline to the subtitle row. In the alerts pop-up it is under the avatar and uses variables to control which is selected.


Packaged the wrong version of the javascript and some template bits. Will release a patch soon
dot.png

Adds a separator when not necessary.

The unsummarise button should be removed from the menu and put where the Resummarise button is. As you click Resummarise, it then changes to "Unsummarise". As it adds unnecessary clutter and should really be in one place.

Also as for the phrases for reactions, it also seems to be missing the name of the reaction. i.e "Thumbs up (Like)"

The phrase for example:
On <a {unsummarizeAlertLinkAttributes}>{reactedcontent}</a>, {name} reacted with {reactions}

Needs to be changed to:
{name} reacted to <a {unsummarizeAlertLinkAttributes}>{reactedcontent}</a> with {reactions}.

But include the name of the reaction too mentioned as above.
 
View attachment 240031

Adds a separator when not necessary.

The unsummarise button should be removed from the menu and put where the Resummarise button is. As you click Resummarise, it then changes to "Unsummarise". As it adds unnecessary clutter and should really be in one place.

Also as for the phrases for reactions, it also seems to be missing the name of the reaction. i.e "Thumbs up (Like)"

The phrase for example:
On <a {unsummarizeAlertLinkAttributes}>{reactedcontent}</a>, {name} reacted with {reactions}

Needs to be changed to:
{name} reacted to <a {unsummarizeAlertLinkAttributes}>{reactedcontent}</a> with {reactions}.

But include the name of the reaction too mentioned as above.
Also to add to this. The "Mark Read" in the menu footer takes you to a page rather than opening up in an overlay.
 
Adds a separator when not necessary.
The separator is automatically added due to css & the usage of <li> for items, fixed for the next version.

Also as for the phrases for reactions, it also seems to be missing the name of the reaction. i.e "Thumbs up (Like)"
This is deliberate, as once you have half a dozen reactions it becomes too noisy. In the template svAlertsImprov_macros, look for 'showtitle': false, and change that to 'showtitle': true, to change.

The unsummarise button should be removed from the menu and put where the Resummarise button is. As you click Resummarise, it then changes to "Unsummarise". As it adds unnecessary clutter and should really be in one place.
The unsummarise button/link is per-alert, while the "resummarise" is on all alerts.

The phrase for example:
On <a {unsummarizeAlertLinkAttributes}>{reactedcontent}</a>, {name} reacted with {reactions}

Needs to be changed to:
{name} reacted to <a {unsummarizeAlertLinkAttributes}>{reactedcontent}</a> with {reactions}.
That makes sense, implemented for the next version.
 
The unsummarise button/link is per-alert, while the "resummarise" is on all alerts.
Yes, this is true but there isn't an "Unsummarise" for all alerts at the time being. So once you click "Resummarise" there is no going back and you'll need to unsummarise each alert. Does that make sense? It's just good to have that option and makes sense to.
 
This is deliberate, as once you have half a dozen reactions it becomes too noisy. In the template svAlertsImprov_macros, look for 'showtitle': false, and change that to 'showtitle': true, to change.

The only thing I see changing here is the number of reactions that's resummarised and since it's resummarised, I didn't think it'd become an issue in terms of noisiness. Once you rephrase the resummarised reaction phrases. I would advise taking out the "x 6" as seen in the screenshot below. It's not necessary when you've rephrased the phrases like that in the next version. For example:
"(user) reacted to 6 of your posts with Like" is better than "(user) reacted to 6 of your posts with Like x 6". Not necessary for the x6. It's better readability without the x 6 added to the phrase and less of the clutter/noise.

resummarise.png

Although, it's customisable via the svAlertsImprov_macros template.
 
Last edited:
Xon updated Alert Improvements by Xon with a new update entry:

2.8.8 - Security fix & bugfix update

  • Fix access check when unsummarizing alerts. This could allow deleting arbitrary alerts for other users, but did not leak contents of that alert.
  • Fix unsummarizating alerts where not correctly marking the alert as unviewed
  • Remove redundant separator when floating mark read/unread right
  • Update phrase used by the reaction summary for a single user giving multiple reactions

Read the rest of this update entry...
 
Hmm maybe you can point me to right direction? When I attempt to install I get... Not sure what that means..Thanks!

he following errors must be resolved before continuing:
  • Alert Improvements requires Standard Library by Xon v1.0.0+.
 
Top Bottom