1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Service Issue Akismet API Key + Follow Message Moderation -> Can't post conversation messages

Discussion in 'Resolved Bug Reports' started by markku, Jun 24, 2014.

  1. markku

    markku Well-Known Member

    XF 1.3.3

    When the two following conditions are met:

    • Akismet API key is set up in the Spam Management options
    • A special user permission added for a user: Follow Message Moderation: Never

    The result is:

    • All regular public posts go to moderation queue waiting for approval -- just like they should.
    • Conversations messages cannot be posted at all, it gives the error: Your content can not be submitted. This is likely because your content is spam-like or contains inappropriate elements. Please change your content or try again later. If you still have problems, please contact an administrator.

    It's not Akismet giving a false positive, because:

    • I tried posting several different private conversation messages, with unique content, and it every time gave the aforementioned error
    • I removed the special user permission (i.e. set Follow Message Moderation: Not Set), but had Akismet still enabled, and the exact same private conversations went through fine


    When the two following conditions are met:
    • Akismet API key removed from Spam Management
    • A special user permission added for a user: Follow Message Moderation: Never

    The result is:

    Regular public posts go to moderation queue, just like they should, and the user can also post private conversations, just like they should.


    Can anyone reproduce, or is this just me?
     
  2. Mike

    Mike XenForo Developer Staff Member

    It is Akismet. Message moderation rules don't have any effect on conversations. Similarly, any behavior that would cause a message to be moderated in a thread will be blocked in places where there is no concept of moderation (conversations, signatures, etc).

    Note that Akismet takes more into account than the message content. Things like IPs, user agent, referrers, email, URLs, etc are considered by it as well.
     
  3. Rudy

    Rudy Well-Known Member

    I should note (for posterity) that I had the exact same issue on my forum. I was trying to send myself a test message from a test account, and looking in the spam log, Akismet was the reason that the message would not get posted. And it was not like these had any spam content in them. I ended up having to disable Akismet just to send the message.

    Now it makes me wonder if users are trying to send private conversations and getting the same errors. Nobody has reported it, but that does not mean it hasn't happened...
     

Share This Page